summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSchwonder Reismus2019-07-14 22:57:13 +0300
committerSchwonder Reismus2019-07-14 22:57:13 +0300
commitd7f6fee8e2c858a479bb6247744b730acdafcd31 (patch)
tree6735dd066b47e6ecb06c0c3ee515d950904b3c25 /PKGBUILD
parent0c3385c4ce577717f3319c8efc056d8a4056e340 (diff)
downloadaur-d7f6fee8e2c858a479bb6247744b730acdafcd31.tar.gz
Improve auto-update from Github
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbad81699f7e..0d9f4bfc7feb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,6 @@ optdepends=('hyphen: Auto-hyphenation support'
'dictd: Offline dictionary support'
'festival: Text-to-speech support; also voice package needed'
'espeak-ng: Text-to-speech support; also voice package needed')
-#source=(https://github.com/johnfactotum/${pkgname}/archive/${pkgver}.tar.gz)
source=($pkgname::git+https://github.com/johnfactotum/$pkgname.git)
provides=($pkgname)
conflicts=($pkgname-git)
@@ -22,13 +21,12 @@ sha256sums=('SKIP')
pkgver() {
cd $srcdir/$pkgname
- git describe --tags
+ git describe --tags | sed -r 's/('$pkgver').+/\1/'
}
build() {
cd $srcdir/$pkgname
- git checkout -b $pkgver
- git pull origin $pkgver
+ git checkout tags/$pkgver
meson build --prefix=/usr
ninja -C build
}