summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarl Smedstad2023-12-11 19:06:20 +0100
committerCarl Smedstad2023-12-11 19:06:20 +0100
commit56a731fa9245f1faf46f63d347959fda122e7cd8 (patch)
tree4d636e6eefd317071bb2fbca08c59114568938ca /PKGBUILD
parent7b638b9572185fce7bdda817165e1b885ea98aa6 (diff)
downloadaur-56a731fa9245f1faf46f63d347959fda122e7cd8.tar.gz
Publish version 2023.12.11.00-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d731024c979e..4ed69036a6bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Daichi Shinozaki <dsdseg@gmail.com>
pkgname=folly
-pkgver=2023.12.04.00
-pkgrel=2
+pkgver=2023.12.11.00
+pkgrel=1
pkgdesc="An open-source C++ library developed and used at Facebook"
arch=(x86_64)
url="https://github.com/facebook/folly"
@@ -34,7 +34,6 @@ depends=(
makedepends=(
boost
cmake
- gmock
gtest
)
provides=(
@@ -43,39 +42,36 @@ provides=(
libfollybenchmark.so
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('6b13903f058fbb795d3c41124fe9df0da6dc07470348868dedafff3c2b106033')
+sha256sums=('1ff0c0258f8322a818a6e0cd27c0fc965360dc04af308e59349e1c79966190a1')
options=(!lto)
_archive="$pkgname-$pkgver"
-prepare() {
- cd "$_archive"
-
- # Remove test that doesn't compile. It requires std::chrono::yeats, not sure
- # how to get that. It's not part of the C++ standard.
- sed -i '/rate_limiter_test/d' CMakeLists.txt
-}
-
build() {
cd "$_archive"
+ # For the tests to compile, C++20 is needed. Building with C++20 produces a
+ # number of compiler warnings, disable them to remove the noise.
cmake -S . -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-Wno-dev \
-DBUILD_TESTS=ON \
-DBUILD_SHARED_LIBS=ON \
- -DPACKAGE_VERSION="$pkgver"
+ -DPACKAGE_VERSION="$pkgver" \
+ -DCMAKE_CXX_STANDARD=20 \
+ -DCMAKE_CXX_FLAGS="-Wno-unused-result -Wno-attributes -Wno-address -Wno-uninitialized -Wno-maybe-uninitialized"
cmake --build build
}
check() {
cd "$_archive"
- # Skip failing tests - not sure why they fail.
_skipped_tests=(
+ # Skip failing tests - not sure why they fail.
'HHWheelTimerTest'
'async_helpers_test'
+ 'concurrent_hash_map_test'
'executor_test'
'fbstring_test'
'future_dag_test'
@@ -89,6 +85,12 @@ check() {
'timekeeper_test'
'wait_test'
'xlog_test'
+
+ # Skip long-running tests.
+ 'concurrent_skip_list_test'
+ 'eliasfano_test'
+ 'f14_fwd_test'
+ 'small_locks_test'
)
_skipped_tests_pattern="${_skipped_tests[0]}"
for test in "${_skipped_tests[@]:1}"; do