summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2021-06-12 07:43:47 +0200
committerMichal Wojdyla2021-06-12 07:43:47 +0200
commitc323e06d6daa34e16671ffa01233468047a96565 (patch)
treeb6efca7d643710cb3ecf7ec30110d0fd8c72e5ea /PKGBUILD
parent371b22258b5543c69cee065bd1831fbe4e557741 (diff)
downloadaur-c323e06d6daa34e16671ffa01233468047a96565.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 10 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64cae47273aa..e4f448e32e16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
# Contributor: Joel Teichroeb <joel@teichroeb.net>
# Contributor: Jonas Heinrich <onny@project-insanity.org>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=folly-git
-pkgver=2019.06.17.00.r21.gefaea2394
+pkgver=2021.05.31.00.r0.g99fbca1df
pkgrel=1
-pkgdesc='C++ library developed and used at Facebook'
-arch=('i686' 'x86_64')
+pkgdesc="An open-source C++ library developed and used at Facebook"
+arch=('x86_64')
url='https://github.com/facebook/folly'
license=('Apache')
conflicts=('folly')
provides=('folly')
-depends=('google-glog' 'gflags' 'double-conversion' 'libevent' 'boost-libs' 'jemalloc' 'xz' 'lz4' 'zstd' 'snappy')
-makedepends=('git' 'boost' 'python2')
+depends=('snappy' 'jemalloc' 'double-conversion' 'gflags' 'google-glog' 'libevent' 'boost'
+ 'boost-libs' 'fmt' 'openssl' 'zlib' 'bzip2' 'xz' 'lz4' 'zstd' 'libsodium')
+makedepends=('cmake' 'gtest' 'gmock' 'git')
source=(git+https://github.com/facebook/folly.git)
md5sums=('SKIP')
@@ -22,21 +23,13 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd folly/folly
- find -name '*.py' -exec sed -i 's|^#!/usr/bin/env python$|#!/usr/bin/env python2|' {} \;
-}
-
build() {
cd folly
- cmake . \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_SHARED_LIBS=ON \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS -fPIC"
+ cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/usr -S . -B _build
+ cmake --build _build
}
package() {
cd folly
- make DESTDIR="$pkgdir" install
+ cmake --build _build --target install -- DESTDIR="$pkgdir/"
}