summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2017-04-21 23:34:43 +0200
committerhaawda2017-04-21 23:34:43 +0200
commitddca677c9b19f89bc8c6468141c7026a56a371e4 (patch)
tree43dfd0340e736084d052f268609112da051c5c54 /PKGBUILD
parentda73cef76c28525b0e6fc48d3e811146a6ff8d64 (diff)
downloadaur-ddca677c9b19f89bc8c6468141c7026a56a371e4.tar.gz
dopt and rewrite
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD67
1 files changed, 18 insertions, 49 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80bc7894ca5a..346286111098 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,63 +1,32 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: <craven@gmx.net>
-# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
-# for more information on packaging from GIT sources.
-
-# Maintainer: Your Name <youremail@domain.com>
pkgname=foment-git
-pkgver=20160506
+pkgver=20170121
pkgrel=1
pkgdesc="Foment scheme"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="https://github.com/leftmike/foment.git"
-license=('unknown')
-groups=()
-depends=()
+license=('custom:BSD')
+depends=('gcc-libs')
makedepends=('git')
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-source=()
-noextract=()
-md5sums=() #generate with 'makepkg -g'
-
-_gitroot=https://github.com/leftmike/foment.git
-_gitname=foment
+provides=('foment')
+conflicts=('foment')
+source=("git+https://github.com/leftmike/foment.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd foment
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
-
- #
- # BUILD HERE
- #
- cd unix
+ cd foment/unix
make
}
package() {
- cd "$srcdir/$_gitname-build"
+ cd foment
install -D unix/release/foment ${pkgdir}/usr/bin/foment
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/$pkgname/LICENCE
}
-
-# vim:set ts=2 sw=2 et: