summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2023-05-04 00:57:26 +0300
committerCaleb Maclennan2023-05-04 00:57:26 +0300
commitac2a65119fd319528667dc8698dbba4af4f7aa3c (patch)
tree6efa3e5b33dbd3d4be78df5e3ece88e00326ccc4 /PKGBUILD
parentf1de3b771780cd580e26dbb6914a4237f00fc347 (diff)
downloadaur-ac2a65119fd319528667dc8698dbba4af4f7aa3c.tar.gz
upgpkg: font-line 3.1.4-3
Rebuild for Python 3.11, normalize PEP517 build tooling
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50a5f4ccd5cb..f5f0a7a1c43b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=font-line
pkgver=3.1.4
-pkgrel=2
+pkgrel=3
pkgdesc='OpenType vertical metrics reporting and font line spacing adjustment tool'
arch=(any)
url="https://github.com/source-foundry/$pkgname"
@@ -11,17 +11,18 @@ depends=(python
python-commandlines
python-fonttools
python-standardstreams)
-makedepends=(python-setuptools-scm)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools-scm)
_archive="$pkgname-$pkgver"
source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('033baa102ab9c61a653f213997610e0de308d5bc75e989923927a0519687cbb1')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}