summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbl00dy18372021-07-04 13:11:38 +0200
committerbl00dy18372021-07-04 13:11:38 +0200
commitc6549508bc85525283e92d969e19d6c792717d73 (patch)
tree84490cd2ff41d255e59eb034c7e649c16e0145a6 /PKGBUILD
downloadaur-c6549508bc85525283e92d969e19d6c792717d73.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66a1f4086d6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+#Maintainter: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
+_pkgname=font8x8
+pkgname=${_pkgname}-git
+pkgver=r7.8e279d2
+pkgrel=1
+pkgdesc="8x8 monochrome bitmap fonts for rendering in c"
+arch=('any')
+url="https://github.com/dhepper/font8x8"
+license=('Custom:CC0')
+makedepends=('git')
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=(git+https://github.com/dhepper/font8x8.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}"/"${_pkgname}"
+ mkdir -p "${pkgdir}"/usr/include/${_pkgname}/
+ mkdir -p "${pkgdir}"/usr/share/doc/${_pkgname}/
+ install -Dm644 *.h "${pkgdir}"/usr/include/${_pkgname}/
+ install -Dm644 *.c "${pkgdir}"/usr/include/${_pkgname}/
+ install -Dm644 README "${pkgdir}"/usr/share/doc/${_pkgname}/
+}