summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2018-11-02 01:09:42 -0400
committerVincent Grande2018-11-02 01:09:42 -0400
commit2a4e1f9dd57334490d783578f099043093c7cca0 (patch)
tree1c215dac15d2e9db7f1ff566fd5620ec5a9b10ee /PKGBUILD
parent0d47d228eddbf8ddf0844512b085a71223306034 (diff)
downloadaur-2a4e1f9dd57334490d783578f099043093c7cca0.tar.gz
disabled docs, testing, removed some deps, and some other bloaty poop
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e32e37580cf3..7fcc1889d9a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,14 @@ arch=(x86_64)
url="https://www.freedesktop.org/wiki/Software/fontconfig/"
license=(custom)
depends=(expat freetype2)
-makedepends=(git autoconf-archive gperf python-lxml python-six docbook-utils docbook-sgml
- perl-sgmls texlive-formatsextra json-c)
+makedepends=(git autoconf-archive gperf python-lxml python-six json-c)
conflicts=(fontconfig)
provides=(fontconfig)
install=fontconfig-git.install
source=("git+https://anongit.freedesktop.org/git/fontconfig"
fontconfig-git.hook)
-sha256sums=(SKIP)
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd fontconfig
@@ -38,15 +38,16 @@ build() {
--with-xmldir=/etc/fonts \
--localstatedir=/var \
--disable-static \
+ --disable-docs \
--with-default-fonts=/usr/share/fonts \
--with-add-fonts=/usr/local/share/fonts
make
}
-check() {
- cd fontconfig
- make -k check
-}
+#check() {
+# cd fontconfig
+# make -k check
+#}
_install_conf() {
install -m644 "$1" "$pkgdir/etc/fonts/conf.avail"