summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDet2015-07-09 13:31:25 +0300
committerDet2015-07-09 13:31:25 +0300
commit758ef677a8c25e31a82552c2efa7a2754d3f6174 (patch)
tree14e2f65a4e70a5fc5c53ae97aba38045d23ef32b /PKGBUILD
downloadaur-758ef677a8c25e31a82552c2efa7a2754d3f6174.tar.gz
Initial import: 2.11.1-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD75
1 files changed, 75 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6165eba682a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: Det
+# Contributors: Joris Steyn, Florian Dejonckheere, Tevin Zhang, Andrea Fagiani, Biru Ionut, Paul Bredbury
+# Installation order: freetype2-ubuntu → fontconfig-ubuntu → cairo-ubuntu
+
+pkgname=fontconfig-ubuntu
+pkgver=2.11.1
+_ubver=0ubuntu6
+pkgrel=3
+pkgdesc="Library for configuring and customizing font access, with Ubuntu's LCD rendering patches."
+arch=('i686' 'x86_64')
+url="https://launchpad.net/ubuntu/+source/fontconfig"
+license=('custom')
+depends=('expat' 'freetype2-ubuntu')
+conflicts=('fontconfig')
+provides=("fontconfig=$pkgver")
+options=('!libtool')
+install=$pkgname.install
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_$pkgver.orig.tar.bz2"
+ "https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_$pkgver-$_ubver.debian.tar.xz"
+ '53-monospace-lcd-filter.patch')
+md5sums=('824d000eb737af6e16c826dd3b2d6c90'
+ 'c445273d4c1e8d4fa3cc9542d06b486f'
+ 'a17e48be6a06bc056574be6756cb9738')
+
+prepare() {
+ cd fontconfig-$pkgver
+
+ # loop debian patches
+ for _f in $(cat ../debian/patches/series); do
+ patch -Np1 -i "../debian/patches/$_f"
+ done
+
+ # patch
+ patch -u conf.d/53-monospace-lcd-filter.conf ../53-monospace-lcd-filter.patch
+}
+
+build() {
+ cd fontconfig-$pkgver
+
+ # make sure there's no rpath trouble and sane .so versioning - FC and Gentoo do this as well
+ msg2 "Running 'libtoolize'.."
+ libtoolize -f
+
+ msg2 "Running 'autoreconf'.."
+ autoreconf -fi
+
+ # Enable Position Independent Code for prelinking
+ export CFLAGS="$CFLAGS -fPIC"
+
+ msg2 "Running './configure'.."
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-templatedir=/etc/fonts/conf.avail \
+ --with-xmldir=/etc/fonts \
+ --localstatedir=/var \
+ --disable-static \
+ --with-default-fonts=/usr/share/fonts \
+ --with-add-fonts=/usr/share/fonts
+
+ msg2 "Running 'make'.."
+ make
+}
+
+package() {
+ cd fontconfig-$pkgver
+
+ msg2 "Running 'make install'.."
+ make DESTDIR="$pkgdir" install
+
+ # License
+ install -Dm0644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+
+ # Docs
+ install -Dm0644 debian/changelog "$pkgdir"/usr/share/doc/fontconfig/changelog
+}