summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-10-26 22:29:06 +0300
committerCaleb Maclennan2020-10-26 22:29:06 +0300
commit8c202845b975ead881fc2719c9134113693422da (patch)
tree67d0c0fdabe4fdd686ed55618befbaad1684b3a9 /PKGBUILD
parent375a38c8d9d06fc58d6a1e6eb8094dbda2649a92 (diff)
downloadaur-8c202845b975ead881fc2719c9134113693422da.tar.gz
upgpkg: fontship 0.6.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 786315796472..d4797a4f2821 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=fontship
-pkgver=0.5.0
-pkgrel=2
+pkgver=0.6.0
+pkgrel=1
pkgdesc='A font development toolkit and collaborative work flow'
arch=('any')
url="https://github.com/theleagueof/$pkgname"
@@ -17,13 +17,11 @@ depends=('diffutils'
'python'
'python-babelfont'
'python-brotli' # fonttools optdepends
- 'python-click'
'python-cffsubr' # ufo2ft optdepends
'python-fontmake'
'python-fonttools'
'python-fs' # fonttools optdepends
'python-lxml' # fonttools optdepends
- 'python-pygit2'
'python-skia-pathops' # ufo2ft optdepends
'python-ufo2ft'
'python-ufonormalizer'
@@ -35,8 +33,14 @@ depends=('diffutils'
'ttfautohint'
'woff2'
'zsh')
+makedepends=('cargo' 'rust')
source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz")
-sha256sums=('9120725cbdff4b65fef1470e0073c669ce3c57bfbc9dc4ee41095f0511ab2d0b')
+sha256sums=('ec5998e0489060a2c9cfe54980513f71ed22526900f5610733be84552936d495')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked
+}
build() {
cd "$pkgname-$pkgver"