summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-10-26 13:14:36 +0300
committerCaleb Maclennan2020-10-26 13:14:36 +0300
commit45c9a473337b1a1e029229dba9c71951ec920df9 (patch)
treeee9b6e88314fc34c323a4c22a3594275ab407989 /PKGBUILD
parent92510b98faa4f59e36b79fc9188a048cc22500fb (diff)
downloadaur-45c9a473337b1a1e029229dba9c71951ec920df9.tar.gz
upgpkg: fontship-git 0.5.0.r62.g378e9ec-1
Update bulid dependencies now that CLI is Rust based
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83ebeeb1879a..73b1cc1e9fe5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=fontship-git
-pkgver=0.4.0.r0.gd52fe11
+pkgver=0.5.0.r62.g378e9ec
pkgrel=1
pkgdesc='A font development toolkit and collaborative work flow'
arch=('any')
@@ -17,7 +17,6 @@ depends=('diffutils'
'python'
'python-babelfont'
'python-brotli' # fonttools optdepends
- 'python-click'
'python-cffsubr' # ufo2ft optdepends
'python-fontmake'
'python-fonttools'
@@ -34,6 +33,7 @@ depends=('diffutils'
'ttfautohint'
'woff2'
'zsh')
+makedepends=('cargo' 'rust')
provides=("${pkgname%-git}")
conflicts=("${provides[@]}")
source=("git+$url.git")
@@ -48,6 +48,7 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
./bootstrap.sh
+ cargo fetch --locked
}
build() {