summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMario Finelli2023-05-09 13:32:13 +0200
committerMario Finelli2023-05-09 13:32:13 +0200
commitc15d90291f1b214de0b6944d29fee23734c43881 (patch)
tree1748bf8258e6666a5615686030b04996f60697a4 /PKGBUILD
parent83a4ffb79006515e2dd7ea26410f8a27a6298775 (diff)
downloadaur-c15d90291f1b214de0b6944d29fee23734c43881.tar.gz
upgpkg: foobar2000 2.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 19 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6967ca337c8b..6235d12669fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,44 @@
# Maintainer: Mario Finelli <mario at finel dot li>
pkgname=foobar2000
-pkgver=1.6.16
+pkgver=2.0
pkgrel=1
pkgdesc="An advanced freeware audio player (uses Wine)"
arch=(i686 x86_64)
-url=http://www.foobar2000.org
+url=https://www.foobar2000.org
license=(custom)
depends=(wine desktop-file-utils)
makedepends=(p7zip wget)
-source=("foobar2000_v$pkgver.exe::https://www.foobar2000.org/download"
+# source_i686=("foobar2000_v$pkgver.exe::${url}/download")
+# source_x86_64=("foobar2000-x64_v$pkgver.exe::${url}/download")
+source=("foobar2000_v$pkgver.exe::${url}/download"
"LICENSE"
"${pkgname}.sh"
"${pkgname}.png"
"${pkgname}.desktop")
install=$pkgname.install
-sha256sums=('9679329dbfacba707d7ea22fcdac0677f5ba98934cfbc1fcbcbcf3134371f263'
+sha256sums=('bd6aab01d782680f6eb481fa72d5fab474b45bb76b225708eabc9b3c2456332b'
'134cf36d7631628bfa4a3830704aa6a9efb6e265660b31d5b487df97aaa32721'
'e9d1f7a8dc182f780d0fb15818c2837ebe0b70abcbef1c849a4185da7c09be7c'
'2031e952d1d1d6cb4c2ff2b879421149f3f0780ca5d3ac03bc9c23fcbbd053d6'
'2b6134997e55ce5ef5014dc266cda71b763949ad683d321246a5143333dd1fa0')
-DLAGENTS=('https::/usr/bin/wget -nH --cut-dirs=3 -r -l 2 -A exe -R '*beta*.exe' %u')
+# sha256sums_i686=('bd6aab01d782680f6eb481fa72d5fab474b45bb76b225708eabc9b3c2456332b')
+# sha256sums_x86_64=('91a7ec18a2a35c89b9cce027695a63831e1388047010561f3a0b30c7cfd3994c')
+DLAGENTS=('https::/usr/bin/wget -nH --cut-dirs=3 -r -l 2 -A exe -R '*beta*.exe' -R '*arm*' %u')
# DLAGENTS=('https::/usr/bin/wget -nH --cut-dirs=3 -r -l 2 -A exe %u')
package() {
+ if [[ "$CARCH" == "x86_64" ]]; then
+ # _source_exe="${pkgname}-x64_v${pkgver}.exe"
+ # 7z can't open the new 64bit executable yet so for now we'll keep using
+ # the legacy 32bit even on 64bit systems
+ _source_exe="${pkgname}_v${pkgver}.exe"
+ else
+ _source_exe="${pkgname}_v${pkgver}.exe"
+ fi
+
# unpack NSIS installer .exe into destination
- 7z x "${pkgname}_v${pkgver}.exe" -x'!$PLUGINSDIR' -x'!$R0' -x'!icons' \
+ 7z x "${_source_exe}" -x'!$PLUGINSDIR' -x'!$R0' -x'!icons' \
-x'!foobar2000 Shell Associations Updater.exe' \
-o"${pkgdir}/usr/share/${pkgname}"