summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072022-03-14 00:23:59 +0100
committersL1pKn072022-03-14 00:23:59 +0100
commit7c699404363cfa6ce6f065456d0c5a591d6f2d50 (patch)
tree2bc1069cd52102c785b3fa677d1aa999462f34f1 /PKGBUILD
parent2afd0062098d0f67f8283ac991bb55ec01bbb52b (diff)
downloadaur-7c699404363cfa6ce6f065456d0c5a591d6f2d50.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d32680c13744..a010d04df53d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase="foosynth-plugin-${_plug}-git"
pkgname=("avisynth-plugin-${_plug}-git"
"vapoursynth-plugin-${_plug}-git"
)
-pkgver=r12.0.g7e39809
+pkgver=12.0.g7e39809
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (Dual interface for Vapoursynth/Avisynth) (GIT version)"
arch=('x86_64')
@@ -19,10 +19,11 @@ makedepends=('git'
)
source=("${_plug}::git+https://github.com/HomeOfAviSynthPlusEvolution/DelogoHD.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d r)"
}
prepare() {
@@ -31,19 +32,18 @@ prepare() {
# unbundled
rm -fr include/{VapourSynth,VSHelper,avisynth}.h
rm -fr include/avs
-
+
mkdir -p build
-
}
build() {
cd "${_plug}/build"
- cmake .. \
+ cmake -S .. -B . \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_CXX_FLAGS="${CXXFLAGS} $(pkg-config --cflags vapoursynth avisynth)"
- make
+ cmake --build .
}
package_avisynth-plugin-delogohd-git() {