summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Eklöf2021-04-21 09:51:13 +0200
committerDaniel Eklöf2021-04-21 09:51:13 +0200
commit3853b7c5d20f4a73a693e6a539bffa4d7e39d176 (patch)
tree92d7eebed6bbce7b5c4eee85fafc28052ea4fd84 /PKGBUILD
parent6e7851097e3c19534d6e85eef4eaf69cf6511cc5 (diff)
downloadaur-3853b7c5d20f4a73a693e6a539bffa4d7e39d176.tar.gz
Run tests in the PGO generate phase
This is needed to ensure *all* generated binaries, including e.g. unittests from pulled in subprojects (like fcft), generate *some* profiling data.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a0e0179b035..b58309b794b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Eklöf <daniel at ekloef dot se>
pkgname=('foot-git' 'foot-terminfo-git')
pkgver=1.7.2
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'aarch64')
url=https://codeberg.org/dnkl/foot
license=(mit)
@@ -53,6 +53,10 @@ build() {
meson configure -Db_pgo=generate build
ninja -C build
+ # Need to run tests here, to ensure *all* generated binaries have
+ # profiling data (including e.g. unit tests from fcft/tllist).
+ ninja -C build test
+
local script_options="--scroll --scroll-region --colors-regular --colors-bright --colors-256 --colors-rgb --attr-bold --attr-italic --attr-underline --sixel"
local tmp_file=$(mktemp)