summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Eklöf2021-06-24 20:33:42 +0200
committerDaniel Eklöf2021-06-24 20:33:42 +0200
commit41b2d56edde407da340eff10e279a5712c5df987 (patch)
treeb3d7289607e27abc79220e00d235983b22283602 /PKGBUILD
parentc4ae1cce495d35f8d636fe3f672f62b79c0d3277 (diff)
downloadaur-41b2d56edde407da340eff10e279a5712c5df987.tar.gz
Add libutf8proc, for grapheme shaping support
Also remove freetype2 dependency (this is from when we build with fcft as a subproject). Use the new -Dterminfo-install-location=disables to prevent the terminfo files from being installed, instead of rm:ing them when packaging.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd5cecc1423e..8953d384333f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgdesc='Wayland terminal emulator - fast, lightweight and minimalistic'
pkgname=foot-git
pkgver=1.7.2
-pkgrel=4
+pkgrel=5
conflicts=('foot')
provides=('foot')
arch=('x86_64' 'aarch64')
@@ -10,7 +10,7 @@ url=https://codeberg.org/dnkl/foot
license=(mit)
makedepends=('meson' 'ninja' 'scdoc' 'python' 'ncurses' 'wayland-protocols' 'tllist') # ‘llvm’, for PGO with clang
checkdepends=('check')
-depends=('libxkbcommon' 'wayland' 'pixman' 'fontconfig' 'freetype2' 'fcft' 'foot-terminfo')
+depends=('libxkbcommon' 'wayland' 'pixman' 'fontconfig' 'libutf8proc' 'fcft' 'foot-terminfo')
optdepends=('libnotify: desktop notifications'
'xdg-utils: URI launching'
'bash-completion: bash completions for foot itself')
@@ -52,7 +52,12 @@ build() {
;;
esac
- meson --prefix=/usr --buildtype=release -Db_lto=true . build
+ meson \
+ --prefix=/usr \
+ --buildtype=release \
+ -Db_lto=true \
+ -Dterminfo-install-location=disabled \
+ . build
if [[ ${do_pgo} == yes ]]; then
find -name "*.gcda" -delete
@@ -104,6 +109,5 @@ check() {
package() {
cd foot
DESTDIR="${pkgdir}/" ninja -C build install
- rm -rf "${pkgdir}/usr/share/terminfo"
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/foot/LICENSE"
}