summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Eklöf2021-05-04 10:11:10 +0200
committerDaniel Eklöf2021-05-04 10:11:10 +0200
commitc4ae1cce495d35f8d636fe3f672f62b79c0d3277 (patch)
tree954957dd16a5ba24f390e6b7dee41a5a92bf1191 /PKGBUILD
parent74068d17b86ea6cdd8aa06a24cd74382d5f5d129 (diff)
downloadaur-c4ae1cce495d35f8d636fe3f672f62b79c0d3277.tar.gz
foot-terminfo-git has been split out to a separate AUR package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 10 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 73a25b204418..bd5cecc1423e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,19 @@
# Maintainer: Daniel Eklöf <daniel at ekloef dot se>
-pkgname=('foot-git' 'foot-terminfo-git')
+pkgdesc='Wayland terminal emulator - fast, lightweight and minimalistic'
+pkgname=foot-git
pkgver=1.7.2
-pkgrel=3
+pkgrel=4
+conflicts=('foot')
+provides=('foot')
arch=('x86_64' 'aarch64')
url=https://codeberg.org/dnkl/foot
license=(mit)
makedepends=('meson' 'ninja' 'scdoc' 'python' 'ncurses' 'wayland-protocols' 'tllist') # ‘llvm’, for PGO with clang
checkdepends=('check')
-depends=('libxkbcommon' 'wayland' 'pixman' 'fontconfig' 'freetype2' 'fcft')
+depends=('libxkbcommon' 'wayland' 'pixman' 'fontconfig' 'freetype2' 'fcft' 'foot-terminfo')
+optdepends=('libnotify: desktop notifications'
+ 'xdg-utils: URI launching'
+ 'bash-completion: bash completions for foot itself')
source=(git+https://codeberg.org/dnkl/foot.git)
sha256sums=('SKIP')
@@ -95,28 +101,9 @@ check() {
ninja -C build test
}
-package_foot-git() {
- pkgdesc="Wayland terminal emulator - fast, lightweight and minimalistic"
- depends+=('foot-terminfo')
- optdepends=('libnotify: desktop notifications'
- 'xdg-utils: URI launching'
- 'bash-completion: bash completions for foot itself')
- conflicts=('foot')
- provides=('foot')
-
+package() {
cd foot
DESTDIR="${pkgdir}/" ninja -C build install
rm -rf "${pkgdir}/usr/share/terminfo"
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/foot/LICENSE"
}
-
-package_foot-terminfo-git() {
- pkgdesc="Terminfo files for the foot terminal emulator"
- depends=('ncurses')
- conflicts=('foot-terminfo')
- provides=('foot-terminfo')
-
- cd foot
- install -dm 755 "${pkgdir}/usr/share/terminfo/f/"
- cp build/f/* "${pkgdir}/usr/share/terminfo/f/"
-}