summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRaphael Nestler2024-05-13 14:36:54 +0200
committerRaphael Nestler2024-05-13 14:36:54 +0200
commit58639c77ec6e49562a3121b3d9ae230fd7ed264b (patch)
treeaf0a186c5ba5f0763c6ebb55eb81cd2755e2eb4b /PKGBUILD
parent5ed9f6c3e37026ffcfd4d95c2413e1a370cbcd97 (diff)
downloadaur-58639c77ec6e49562a3121b3d9ae230fd7ed264b.tar.gz
Inject version information on build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e95312fd2ab..de9df71e2704 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=forego
pkgver=1.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Foreman in Go"
arch=('x86_64')
url="https://github.com/jpillora/forego"
@@ -24,7 +24,7 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build -o build
+ go build -ldflags "-s -w -X main.Version=${pkgver}-arch" -o build
}
check() {