summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-03-05 12:54:47 -0600
committerLuis Martinez2021-03-05 12:54:47 -0600
commit50daaa732c5100303829279bcf727e06935a2971 (patch)
treebb15c8bbba4231dfe51891e08b6bf71c0e9c3182 /PKGBUILD
downloadaur-50daaa732c5100303829279bcf727e06935a2971.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79d2ea522180
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: lmartinez-mirror
+pkgname=forgit-git
+_pkgname=${pkgname%-git}
+pkgver=r273.c57c9f9
+pkgrel=1
+pkgdesc="Utility tool powered by fzf for using git interactively"
+arch=('any')
+url="https://github.com/wfxr/forgit"
+license=('MIT')
+groups=('fish-plugins' 'zsh-plugins')
+depends=('fzf')
+optdepends=('bash: supported shell'
+ 'zsh: supported shell'
+ 'fish: supported shell'
+ 'delta: human readable diffs'
+ 'diff-so-fancy: human readable diffs'
+ 'bat: syntax highlighting for .gitignore'
+ 'emoji-cli: emoji support for git log')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+
+ # fish install
+ install -Dm 644 conf.d/forgit.plugin.fish "$pkgdir/etc/fish/conf.d/forgit.plugin.fish"
+
+ # license
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}