summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEvaggelos Balaskas2019-08-15 12:31:32 +0300
committerEvaggelos Balaskas2019-08-15 12:31:32 +0300
commitd86414ce8878e825b729eac9c0957d766de71235 (patch)
treea033f2fea47d86205841be4e1084c683ecf23e13 /PKGBUILD
downloadaur-d86414ce8878e825b729eac9c0957d766de71235.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..adb344d91a2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Evaggelos Balaskas <evaggelos [_AT_] balaskas [_DOT]_ gr>
+pkgname=forkstat
+pkgdesc="logs process fork(), exec() and exit() activity."
+
+pkgver=0.02.11
+pkgrel=1
+
+arch=('x86_64')
+license=('GPL2')
+
+makedepends=(
+ 'make'
+ 'gcc'
+)
+
+url="https://github.com/ColinIanKing/${pkgname}"
+
+source=(
+ ${url}/archive/V${pkgver}.tar.gz
+)
+
+sha256sums=(
+ '357518689e3f93b77dea7efcf61171b874d44eb8f32be61ac281672b84bbfcbb'
+)
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 ${pkgname}.8 "$pkgdir/usr/share/man/man8/${pkgname}.8"
+}
+
+# vim: sts=2 sw=2 ts=2 et \ No newline at end of file