summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDouglas Iuri Medeiros Cabral2022-11-12 11:42:24 -0300
committerDouglas Iuri Medeiros Cabral2022-11-12 11:42:24 -0300
commit94595fa6a614294cb816b64036767ed4c49183a7 (patch)
treed256cf4008f9fff5d6169e876f969d1c8f9e6f95 /PKGBUILD
parent16cb932027e0e53360cbe6601e5e4052eb69a680 (diff)
downloadaur-94595fa6a614294cb816b64036767ed4c49183a7.tar.gz
Added systemd to depends and improves the install script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c4e73cc9549..7b9b3904e09e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Douglas Iuri Medeiros Cabral <douglasimcabral at zohomail dot com>
pkgname=forticlient-vpn
pkgver=7.0.0.0018
-pkgrel=1
-pkgdesc="Build through the official package of FortiClient VPN"
+pkgrel=2
+pkgdesc="Build through the official package of FortiClient VPN only"
arch=("x86_64")
url="https://www.fortinet.com/support/product-downloads"
license=('custom:fortinet')
-depends=('nss' 'gtk3' 'libxss' 'polkit' 'openssl' 'libnotify' 'org.freedesktop.secrets' 'libappindicator-gtk2')
+depends=('systemd' 'nss' 'gtk3' 'libxss' 'polkit' 'openssl' 'libnotify' 'org.freedesktop.secrets' 'libappindicator-gtk2')
optdepends=(
'mate-polkit: for polkit authentication for the MATE'
'polkit-gnome: for polkit authentication for the GNOME'
@@ -32,15 +32,9 @@ package() {
# Install license
install -Dm 644 "${pkgdir}/usr/share/doc/forticlient/copyright" "${pkgdir}/usr/share/licenses/fortinet/LICENSE"
- # Symbolic binaries which are located in /opt
+ # Symbolic link to fortivpn CLI
mkdir -p ${pkgdir}/usr/bin
ln -sf '/opt/forticlient/fortivpn' "${pkgdir}/usr/bin/fortivpn"
- ln -sf '/opt/forticlient/gui/FortiClient-linux-x64/FortiClient' "${pkgdir}/usr/bin/forticlient"
-
- # Symbolic launchers
- mkdir -p ${pkgdir}/etc/xdg/autostart
- ln -sf '/opt/forticlient/Fortitray.desktop' "${pkgdir}/etc/xdg/autostart/Fortitray.desktop"
- ln -sf '/opt/forticlient/Fortivpn.desktop' "${pkgdir}/etc/xdg/autostart/Fortivpn.desktop"
}