summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-04-23 10:57:17 +0800
committerzxp198210052024-04-23 10:57:17 +0800
commite4501053d57c85093063481bbbe3836742ece26c (patch)
tree62ea96be5a897e83893d4491f695992e63e44f40 /PKGBUILD
parent3a44ae73223d71a4dba980f47e86021e119af61e (diff)
downloadaur-e4501053d57c85093063481bbbe3836742ece26c.tar.gz
update to 1.63.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 22 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5a09271b0f3..808786ed3d0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,27 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
-
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=fortio-bin
-pkgver=1.38.4
+pkgver=1.63.7
pkgrel=1
pkgdesc='Fortio load testing library, command line tool, advanced echo server and web UI in go (golang). Allows to specify a set query-per-second load and record latency histograms and other useful stats'
-arch=('x86_64')
+arch=(
+ 'aarch64'
+ 'x86_64'
+)
url="https://fortio.org"
-license=('Apache')
-provides=('fortio')
-makedepends=('tar')
-noextract=("${pkgname}-${pkgver}")
-source=("${pkgname}-${pkgver}.tgz::https://github.com/fortio/fortio/releases/download/v${pkgver}/fortio-linux_amd64-${pkgver}.tgz")
-sha256sums=('ea0cf5cf3e76957693c627b9a18c3fc41f67cb1dbb8b4625b0ee5a0308b9d7a0')
-
-package() {
- cd "${srcdir}"
- tar xvf ${pkgname}-${pkgver}.tgz -C "${pkgdir}"
+_ghurl="https://github.com/fortio/fortio"
+license=('Apache-2.0')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=()
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_arm64.deb")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb")
+sha256sums_aarch64=('55cd655a0b7d7ec7b4ce1dc1359734f3f263c1b339644bd85d2e441e0e1d1785')
+sha256sums_x86_64=('7aa5b6c9800738aeaf2e80b68ed8720945025dae134fc9e0bc793a01e23928c9')
+build() {
+ bsdtar -xf "${srcdir}/data."*
}
-# vim:set ts=2 sw=2 et:
+package() {
+ install -Dm755 "${srcdir}/usr/bin/${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm644 "${srcdir}/usr/share/man/man1/${pkgname%-bin}.1" -t "${pkgdir}/usr/share/man/man1"
+} \ No newline at end of file