summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmmon Smith2017-02-16 16:07:12 -0800
committerAmmon Smith2017-02-16 16:08:09 -0800
commit7e8a670aa3c734592b1a83117c5db1222d5cc17c (patch)
treed013b37fd89d2a74a16d149a59e91de26c553df3 /PKGBUILD
downloadaur-7e8a670aa3c734592b1a83117c5db1222d5cc17c.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..317277370fa7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ammon Smith <ammon.i.smith@gmail.com>
+
+pkgname=fortune-mod-houseofcards
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='Fortune quotes from "House of Cards".'
+arch=('any')
+license=('unknown')
+install="$pkgname.install"
+makedepends=('bsd-games') # for rot13
+depends=('fortune-mod')
+groups=('fortune-mods')
+_name='houseofcards'
+source=("$_name.txt")
+sha256sums=('1c90d15eef9bfcf37f5aaee49dd6c0d8ada74e15859f090981da609d98c691cb')
+
+build() {
+ cd "$srcdir"
+ rot13 < "$_name.txt" > "$_name"
+ strfile -x "$_name" "$_name.dat"
+}
+
+package() {
+ install -D -m644 "$srcdir/$_name" "$pkgdir/usr/share/fortune/$_name"
+ install -D -m644 "$srcdir/$_name.dat" "$pkgdir/usr/share/fortune/$_name.dat"
+}
+