summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée2015-07-08 18:17:08 +0200
committerMattias Andrée2015-07-08 18:17:08 +0200
commitce431dec17f729c06fc16f45408379076f5fe9a1 (patch)
tree2549642593878c271003d7892ca1b79f3598e69b /PKGBUILD
downloadaur-ce431dec17f729c06fc16f45408379076f5fe9a1.tar.gz
Initial import, version 1504030105
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6297890eb30e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=fortune-mod-metalocalypse
+pkgver=1504030105
+pkgrel=1
+_ver=5
+pkgdesc="Fortune quotes from Metalocalypse"
+arch=('any')
+license=('custom:cc-sa-3.0')
+url=("http://en.wikiquote.org/wiki/Metalocalypse")
+depends=('fortune-mod')
+makedepends=('fortune-mod' 'make' 'coreutils' 'sed' 'grep' 'wikiquote-fortune>=1.4')
+source=("https://github.com/maandree/wikiquote-fortune-collection/archive/${_ver}.tar.gz")
+sha256sums=(f25b0e335782fc59bf960e5f09c16ebd0bd38cb9cb174f0338c6ba5f8d3013b5)
+
+
+build()
+{
+ cd "${srcdir}/wikiquote-fortune-collection-${_ver}"
+ make SHOWS=metalocalypse SCRIPTS=
+}
+
+package()
+{
+ cd "${srcdir}/wikiquote-fortune-collection-${_ver}"
+ cd quotes/metalocalypse
+ install -dm755 -- "${pkgdir}/usr/share/fortune"
+ install -m644 -- metalocalypse metalocalypse.dat "${pkgdir}/usr/share/fortune"
+}
+