summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthias Devlamynck2015-06-12 21:28:33 +0200
committerMatthias Devlamynck2015-06-12 21:28:33 +0200
commit7405e2d9ab27f5c3d1bfc5769cf202049ab3ae3a (patch)
treecaee9a325cea04f24bb2277eb5ee5c19322fccb6 /PKGBUILD
downloadaur-7405e2d9ab27f5c3d1bfc5769cf202049ab3ae3a.tar.gz
Initial Commit, import package
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..113450e6d06e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+
+# Maintainer : mdevlamynck <matthias.devlamynck@mailoo.org>
+
+pkgname=fortune-mod-mlp
+_gitname=ponysay
+_gitrepo=https://github.com/erkin/ponysay.git
+pkgver=3.0.2.50.ge06f67c
+pkgrel=1
+pkgdesc="Fortune quotes from My Little Pony Friendship is Magic. Quotes come from ponysay."
+arch=('any')
+license=('GPL3')
+url=('http://erkin.github.com/ponysay/')
+depends=('fortune-mod')
+source=("git+${_gitrepo}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_gitname}
+ git describe|sed "s/-/./g"
+}
+
+build()
+{
+ cd "${srcdir}/${_gitname}"
+ cd extras/fortune-mod-mlp
+ chmod u+x name-pony.sh
+ make
+}
+
+package()
+{
+ cd "${srcdir}/${_gitname}/extras/fortune-mod-mlp"
+ install -dm755 ${pkgdir}/usr/share/fortune
+ install -m755 pony* ${pkgdir}/usr/share/fortune
+}
+