summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée2015-07-08 18:18:26 +0200
committerMattias Andrée2015-07-08 18:18:26 +0200
commitdbf2c82d11da5b97ff0d7b0570620e472260f48f (patch)
tree5e40a4d3a727d9998442fb688a24e8ffe9f6ee8a /PKGBUILD
downloadaur-dbf2c82d11da5b97ff0d7b0570620e472260f48f.tar.gz
Initial import, version 1403181321
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d07d1e4e5ed1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=fortune-mod-tgagaapp
+pkgver=1403181321
+pkgrel=1
+_ver=5
+pkgdesc="Fortune quotes from Two Guys, a Girl and a Pizza Place"
+arch=('any')
+license=('custom:cc-sa-3.0')
+url=("http://en.wikiquote.org/wiki/Two_Guys,_a_Girl_and_a_Pizza_Place")
+depends=('fortune-mod')
+makedepends=('fortune-mod' 'make' 'coreutils' 'sed' 'grep' 'wikiquote-fortune>=1.4')
+source=("https://github.com/maandree/wikiquote-fortune-collection/archive/${_ver}.tar.gz")
+sha256sums=(f25b0e335782fc59bf960e5f09c16ebd0bd38cb9cb174f0338c6ba5f8d3013b5)
+
+
+build()
+{
+ cd "${srcdir}/wikiquote-fortune-collection-${_ver}"
+ make SHOWS=tgagaapp SCRIPTS=
+}
+
+package()
+{
+ cd "${srcdir}/wikiquote-fortune-collection-${_ver}"
+ cd quotes/tgagaapp
+ install -dm755 -- "${pkgdir}/usr/share/fortune"
+ install -m644 -- tgagaapp tgagaapp.dat "${pkgdir}/usr/share/fortune"
+}
+