summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée2015-07-08 18:18:43 +0200
committerMattias Andrée2015-07-08 18:18:43 +0200
commit6eca968b941116d159b31365a1eb47d6bf1623b9 (patch)
tree411d3e155902bb1af77aaae011ecaaf734fd8c75 /PKGBUILD
downloadaur-6eca968b941116d159b31365a1eb47d6bf1623b9.tar.gz
Initial import, version 1504091531
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1f045d3e160
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=fortune-mod-theshield
+pkgver=1504091531
+pkgrel=1
+_ver=5
+pkgdesc="Fortune quotes from The Shield"
+arch=('any')
+license=('custom:cc-sa-3.0')
+url=("http://en.wikiquote.org/wiki/The_Shield")
+depends=('fortune-mod')
+makedepends=('fortune-mod' 'make' 'coreutils' 'sed' 'grep' 'wikiquote-fortune>=1.4')
+source=("https://github.com/maandree/wikiquote-fortune-collection/archive/${_ver}.tar.gz")
+sha256sums=(f25b0e335782fc59bf960e5f09c16ebd0bd38cb9cb174f0338c6ba5f8d3013b5)
+
+
+build()
+{
+ cd "${srcdir}/wikiquote-fortune-collection-${_ver}"
+ make SHOWS=theshield SCRIPTS=
+}
+
+package()
+{
+ cd "${srcdir}/wikiquote-fortune-collection-${_ver}"
+ cd quotes/theshield
+ install -dm755 -- "${pkgdir}/usr/share/fortune"
+ install -m644 -- theshield theshield.dat "${pkgdir}/usr/share/fortune"
+}
+