summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip2016-04-28 14:09:54 +0200
committerJosip2016-04-28 14:09:54 +0200
commit06c21c82a4e134b8a885e40ea366dac33f63a3f9 (patch)
treefe0d32f9212c025104558b49d063fa6399bc8fe1 /PKGBUILD
parent1e3ecd31d8367e34eed513e77930b2cfcf717aef (diff)
downloadaur-06c21c82a4e134b8a885e40ea366dac33f63a3f9.tar.gz
Use hooks...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b09b08e40447..1f653c94fcc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,32 @@
+# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+# Contributor:
+
pkgname=fotowall
pkgver=0.9
-pkgrel=1
+pkgrel=2
pkgdesc="A creative tool that allows you to layout your photos or pictures in a personal way"
arch=('i686' 'x86_64')
url="http://www.enricoros.com/opensource/fotowall/"
license=('GPL2')
depends=('qt4' 'v4l-utils')
-install="${pkgname}.install"
source=("http://fotowall.googlecode.com/files/Fotowall-${pkgver}.tar.bz2")
sha256sums=('e4d0c005d2cb1d7c09438bfc3098eadebc08946e4fbc0655b7fc8b046de3810d')
prepare() {
- cd Fotowall-${pkgver}
- # for hidden-file-or-dir warning
- sed -i -e "s/\.build/build/" ${pkgname}.pro
- # for v4l1 compatibility
- sed -i -e 's/linux\/videodev.h/libv4l1-videodev.h/' 3rdparty/videocapture/VideoDevice.h
+ cd Fotowall-${pkgver}
+ # for hidden-file-or-dir warning
+ sed -i -e "s/\.build/build/" ${pkgname}.pro
+ # for v4l1 compatibility
+ sed -i -e 's/linux\/videodev.h/libv4l1-videodev.h/' 3rdparty/videocapture/VideoDevice.h
}
build() {
- cd Fotowall-${pkgver}
- qmake-qt4 PREFIX=/usr
- make
+ cd Fotowall-${pkgver}
+ qmake-qt4 PREFIX=/usr
+ make
}
package() {
- cd Fotowall-${pkgver}
- make INSTALL_ROOT="${pkgdir}/" install
-} \ No newline at end of file
+ cd Fotowall-${pkgver}
+ make INSTALL_ROOT="${pkgdir}/" install
+}