summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2020-11-30 22:46:09 +0100
committerhaawda2020-11-30 22:46:09 +0100
commit915b09be53738221c3222891ddd12d7a3d4e45ab (patch)
tree0e3d22b80e59464be269ece2213d3be3a47d3c26 /PKGBUILD
parent83cac8bb5e1f36b4f95f2b2b98de593161445c96 (diff)
downloadaur-915b09be53738221c3222891ddd12d7a3d4e45ab.tar.gz
patch Makefile
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bebd5e1dc353..7c3e4985ef89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=fotoxx-test
-pkgver=21.28
+pkgver=21.29
pkgrel=1
pkgdesc="A program for improving image files made with a digital camera, test version"
url="http://www.kornelix.net/fotoxx/fotoxx.html"
@@ -13,24 +13,24 @@ optdepends=('rawtherapee: for raw image processing'
'hugin: for panorama photos')
conflicts=('fotoxx')
provides=('fotoxx')
-source=("http://www.kornelix.net/downloads/downloads/${pkgname%-test}-$pkgver-test.tar.gz")
-sha512sums=('91c877a0e5e469f2389590ea9dc13c735ac51202ce1f377eeadd7a7aa77d34475f266ceb84bbbc208499f01da5d5edd8201e94f9683c350a1ed5c16b4e2bfb72')
+source=("http://www.kornelix.net/downloads/downloads/${pkgname%-test}-$pkgver-test.tar.gz" Makefile.patch)
+sha256sums=('be32db72bcd9c6efe88e304b2a210ea0640e01341120cfd910f697aee069925b'
+ '91a603e77dc9836919fe4d12e89ca826330f8009cf726dd681a5e64ca42096a8')
prepare() {
cd ${pkgname%-test}
- sed -i 's+libchamplain+champlain+g' Makefile
- chmod o+r images/color-mode.jpg
+ patch -Np1 < "$srcdir"/Makefile.patch
}
build() {
- cd ${pkgname%-test}
+ cd ${pkgname%-test}
make PREFIX=/usr
}
package() {
cd ${pkgname%-test}
make DESTDIR="$pkgdir" PREFIX=/usr ICONDIR=/usr/share/pixmaps install
- rm -r "$pkgdir"/usr/share/appdata
+
sed -i 's+/usr/share/fotoxx/icons/++' "$pkgdir"/usr/share/applications/${pkgname%-test}.desktop
sed -i 's+Icon=fotoxx.png+Icon=fotoxx+' "$pkgdir"/usr/share/applications/${pkgname%-test}.desktop
}