summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXeonacid2024-02-28 15:51:55 +0800
committerXeonacid2024-02-28 15:51:55 +0800
commit217ee28b559afe00f260b233a417ddbf52107d68 (patch)
tree704755fa4c0e9185565220eeda452203ed844913 /PKGBUILD
parent6c17552f57e553cadd38018723c42a60011081d7 (diff)
downloadaur-217ee28b559afe00f260b233a417ddbf52107d68.tar.gz
fix provides/conflicts
Signed-off-by: Xeonacid <h.dwwwwww@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f70e564060b6..bc297043a388 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,13 @@ pkgname=foundryup-git
pkgver=r3227.551bcb5
pkgrel=1
pkgdesc="Update or revert to a specific Foundry branch with ease"
+license=('MIT OR Apache-2.0')
arch=(any)
url=https://github.com/Harry24k/adversarial-attacks-pytorch
depends=(cargo bash)
makedepends=(git)
-license=('MIT OR Apache-2.0')
+provides=(foundryup)
+conflicts=(foundryup)
source=(git+https://github.com/foundry-rs/foundry.git)
sha256sums=('SKIP')
install='post.install'
@@ -22,5 +24,6 @@ pkgver() {
package() {
cd "$_name"
install -Dm755 foundryup/foundryup -t "$pkgdir/usr/bin"
+ install -Dm644 foundryup/README.md -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm644 LICENSE-MIT -t "$pkgdir/usr/share/licenses/$pkgname"
}