summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeorize2018-01-13 13:21:03 +0700
committerLeorize2018-01-13 13:21:03 +0700
commitd6e4f4b947a6ab884db601de24cd1af388353de7 (patch)
treed8976ffedddbf0aac768e7a67f0fb7d8e2b42339 /PKGBUILD
parentdf4e9111af941e90055d4e8dc96bb7cc15ad9ff1 (diff)
downloadaur-d6e4f4b947a6ab884db601de24cd1af388353de7.tar.gz
Updates
Now featuring correct handling of $_build_docs variable, also disable it by default as linking errors are met during build Drop $MAKEFLAGS from make invocation as make generally fetches the content anyway
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 128075485f5a..993fe7639216 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,12 @@
# See http://bbs.archlinux.org/viewtopic.php?t=9318&highlight=fpc
# Build docs
-_build_docs=1
+_build_docs=0
pkgbase='fpc-svn'
pkgname=('fpc-svn' 'fpc-src-svn')
-[[ $_build_docs ]] && pkgname+=('fpc-docs-svn')
-pkgver=3.1.1.r35945
+[ $_build_docs -ne 0 ] && pkgname+=('fpc-docs-svn')
+pkgver=3.1.1.r37950
_pkgver=${pkgver%.r*}
pkgrel=1
arch=('i686' 'x86_64')
@@ -22,8 +22,8 @@ license=('GPL' 'LGPL' 'custom')
depends=('ncurses' 'zlib' 'expat')
# Trunk can only be built with stable version of FPC
makedepends=('fpc<9999' 'subversion')
-[[ $_build_docs ]] && makedepends+=('texlive-core' 'texlive-htmlxml'
- 'texlive-latexextra' 'ghostscript')
+[ $_build_docs -ne 0 ] && makedepends+=('texlive-core' 'texlive-htmlxml'
+ 'texlive-latexextra' 'ghostscript')
source=(fpcbuild::svn+http://svn.freepascal.org/svn/fpcbuild/trunk)
sha1sums=('SKIP')
@@ -39,10 +39,10 @@ build() {
pushd fpcsrc/compiler
fpcmake -Tall
popd
- make "${MAKEFLAGS}" NOGDB=1 OPT=' -dRelease' build
+ make NOGDB=1 OPT=' -dRelease' build
cd fpcdocs
- [[ $_build_docs ]] && make -j1 FPCSRCDIR="${srcdir}"/fpcbuild/fpcsrc html
+ [ $_build_docs -ne 0 ] && make -j1 FPCSRCDIR="${srcdir}"/fpcbuild/fpcsrc html
}
package_fpc-svn() {