summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTimothy Gu2020-03-19 23:53:58 -0400
committerTimothy Gu2020-03-19 23:53:58 -0400
commit6142d451ba0a2e4a1ce332f1ea518f2e3f713170 (patch)
treed8362d905603bc50af6a0baa35b6d53c937d34f3 /PKGBUILD
parent33b7a43aadfcd4fac8ccddd65a677da67c7df358 (diff)
downloadaur-6142d451ba0a2e4a1ce332f1ea518f2e3f713170.tar.gz
Bump to 1.90.1+61+gd27872f; use official pam_wrapper
The AUR python-pypamtest package will be removed soon.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce7c6b723410..edf1fd969916 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgname=fprintd-libfprint2
_pkgname=fprintd
-pkgver=1.90.1+12+g750a815
-pkgrel=2
+pkgver=1.90.1+61+gd27872f
+pkgrel=1
pkgdesc="D-Bus service to access fingerprint readers"
arch=(x86_64)
url="https://www.freedesktop.org/wiki/Software/fprint/fprintd"
@@ -16,16 +16,16 @@ optdepends=('pam: to use the fprintd pam plugin')
provides=(fprintd)
conflicts=(fprintd)
makedepends=(intltool git gtk-doc meson pam)
-checkdepends=(python-cairo python-dbus python-dbusmock python-gobject python-pypamtest)
+checkdepends=(pam_wrapper python-cairo python-dbus python-dbusmock python-gobject)
groups=(fprint)
-source=(
- "git+https://gitlab.freedesktop.org/libfprint/fprintd.git"
- 'disable-systemd-protection.patch'
-)
-sha256sums=(
- 'SKIP'
- '4854d32d6579de31fd59b4df02f6a29db2e266dedfe9edda13bedcda1b083be1'
-)
+source=("git+https://gitlab.freedesktop.org/libfprint/$_pkgname.git"
+ '53.patch'
+ '54.patch'
+ 'disable-systemd-protection.patch')
+sha256sums=('SKIP'
+ 'd64ace799a6c6a3ea4ee56be104b3bdba6fe913329c25672205e2a3ebb897e6a'
+ '1121efbc74182c8c742397581f78d9f1b0388487617434b81fc7f9abea1a3832'
+ '4854d32d6579de31fd59b4df02f6a29db2e266dedfe9edda13bedcda1b083be1')
pkgver() {
cd $_pkgname
@@ -34,6 +34,7 @@ pkgver() {
prepare() {
cd $_pkgname
+ git apply "$srcdir/53.patch" "$srcdir/54.patch"
patch -p1 -i "${srcdir}/disable-systemd-protection.patch"
}