summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Dunn2019-12-21 22:22:17 +0000
committerAdam Dunn2019-12-21 22:22:17 +0000
commit8446f5cfe6c9057deffa5f9c99f4fb40b1f606fe (patch)
tree96b565ce0213b147638e14571e2823de32567779 /PKGBUILD
parent34d295b7722db6c000e82da323bab8550be0baa7 (diff)
downloadaur-framecounter.tar.gz
Update to latest revision in git repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e4a31797713..b3b57aeae63a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
pkgname=framecounter
-pkgver=20140128
+pkgver=20171226
pkgrel=1
pkgdesc="A small program to count frames in RAW VC-1, MPEG-4 ASP and MPEG-4 AVC streams"
arch=('i686' 'x86_64')
license=('custom')
depends=('qt5-base')
+makedepends=('git')
url="http://www.selur.de/"
-source=(http://www.selur.de/sites/default/files/hybrid_downloads/FrameCounter.7z)
-md5sums=('02b1c2fbd672f5169b58957dd552fefb')
+_commit=0189dbfb3a1891c520746bf82aca78199b24fbb9
+source=(git+https://github.com/Selur/FrameCounter.git#tag=$_commit)
+sha256sums=(SKIP)
build() {
- cd "${srcdir}"/FrameCounter/FrameCounter/source
+ cd "${srcdir}"/FrameCounter
qmake FrameCounter.pro
make
}
package() {
- cd "${srcdir}"/FrameCounter/FrameCounter/source
+ cd "${srcdir}"/FrameCounter
install -D -m755 FrameCounter "${pkgdir}"/usr/bin/FrameCounter
}