summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-05-30 17:49:51 +0300
committerCaleb Maclennan2020-05-30 17:49:51 +0300
commit9df34ce24c3d537a384098d630fd5548c31ae81f (patch)
tree402bb048f5dfd46a3ca7576041fd718df7355fe6 /PKGBUILD
downloadaur-9df34ce24c3d537a384098d630fd5548c31ae81f.tar.gz
Initial upload: fraunces-font 0.001-1
Note upstream font identifies as 1.000 but the project also claims it isn't released as that version yet so I set the version to be something low until they officially announce the version.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db281fbe068b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_project=fraunces
+pkgbase=${_project}-font
+pkgname=("ttf-$_project-variable") # "ttf-$_project" "otf-$_project"
+pkgver=0.001
+_sha=611c698e29de78d133beac7534a0ac7b914682cb
+pkgrel=1
+pkgdesc='A display, “Old Style” soft-serif typeface inspired by early 20th century typefaces'
+arch=('any')
+url="https://github.com/undercasetype/${_project^}"
+license=('OFL')
+source=("$url/archive/$_sha/$pkgname-$pkgver.zip")
+sha256sums=('44b6f52536b8fdabae2e938344befbe2bacbc7800909c086401f4a28197fad7e')
+
+package_otf-fraunces () {
+ :
+}
+
+package_ttf-fraunces () {
+ :
+}
+
+package_ttf-fraunces-variable () {
+ pkgdesc+=" (variable)"
+ cd "${_project^}-$_sha"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" fonts/*\[*\].ttf
+ install -Dm644 OFL.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+}