summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Goldsmith2017-03-18 13:07:20 -0400
committerAdam Goldsmith2017-03-18 13:11:13 -0400
commitce33472c6213604829d322b54c3f6750d7d4a76b (patch)
treeea0f4b0af9eadc8a37e577ebdf18ec82db345162 /PKGBUILD
downloadaur-ce33472c6213604829d322b54c3f6750d7d4a76b.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c569178431a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+pkgname=frc-ctrelib-cpp
+pkgver=4.4.1.12
+pkgrel=1
+pkgdesc="Library for the for the FRC roboRIO"
+arch=(i686 x86_64)
+url="http://www.ctr-electronics.com/hro.html#product_tabs_technical_resources"
+license=('custom')
+groups=('frc-2017')
+depends=('arm-frc-linux-gnueabi-wpilib')
+makedepends=()
+options=('!strip' 'libtool' 'staticlibs' '!emptydirs')
+source=("http://www.ctr-electronics.com/downloads/lib/CTRE_FRCLibs_NON-WINDOWS_v${pkgver}.zip")
+sha512sums=('abe152427bacf5afc870f9d8137930f456c384a84a8c1c15d07de0236918bda2acd076722c7c7e166d855573ea591cd8f754bc0fd3a95dd83877e3112f0aab16')
+
+package() {
+ cd "$srcdir/"
+
+ mkdir -p $pkgdir/usr/arm-frc-linux-gnueabi/
+ cp -r cpp/include cpp/lib $pkgdir/usr/arm-frc-linux-gnueabi/
+
+ # Avoid conflicts, badly
+ rm $pkgdir/usr/arm-frc-linux-gnueabi/include/ctre/CtreCanNode.h \
+ $pkgdir/usr/arm-frc-linux-gnueabi/include/ctre/ctre.h
+}