summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph J. Thompson2015-07-02 13:32:31 +0200
committerChristoph J. Thompson2015-07-02 13:32:31 +0200
commit8ecd62586d7e9f15a4f419c36ac9c531daa290ca (patch)
treed68b7fbac53e78f8c189d899ffd3d8697a8d7232 /PKGBUILD
downloadaur-8ecd62586d7e9f15a4f419c36ac9c531daa290ca.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b001fc2ba797
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Christoph J. Thompson <thompsonc@protonmail.ch>
+
+pkgname=freeblocks
+pkgver=0.5
+pkgrel=1
+pkgdesc="Tetris Attack-like puzzle game"
+arch=('i686' 'x86_64')
+url="http://github.com/dorkster/freeblocks"
+license=('GPL3')
+depends=('sdl' 'sdl_image' 'sdl_mixer' 'sdl_ttf')
+makedepends=('cmake')
+source=(https://github.com/dorkster/freeblocks/archive/v${pkgver}.tar.gz)
+sha256sums=(8da72ccf7bcba585fcd8b65943f590f51aff06286f3ed920a13c0c90fb392e06)
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+