summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph J. Thompson2015-08-24 07:40:24 +0200
committerChristoph J. Thompson2015-08-24 07:40:24 +0200
commit8c6905f35a12e1252e6fef6306f301d363611b3e (patch)
tree2dcda158149e844f44feb3364d916502e7fbc11c /PKGBUILD
downloadaur-8c6905f35a12e1252e6fef6306f301d363611b3e.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a90681413850
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Christoph J. Thompson <thompsonc@protonmail.ch>
+
+pkgname=freeblocks-git
+pkgver=r181.g68b11ed
+pkgrel=1
+pkgdesc="Tetris Attack-like puzzle game"
+arch=('i686' 'x86_64')
+url="https://github.com/dorkster/freeblocks"
+license=('GPL3')
+depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf')
+makedepends=('git' 'cmake')
+conflicts=('freeblocks')
+provides=('freeblocks')
+replaces=('freeblocks')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.g%s" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}
+