summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGabriel Souza Franco2019-10-21 18:39:19 +0200
committerGabriel Souza Franco2019-10-21 18:39:19 +0200
commitbbaad292b20daffda5d86d95a580b62c9a18c40a (patch)
tree39fe7d6645b793892b1d385674fb4843ae8ba64b /PKGBUILD
parent4da14a87bcd3476ed875c7dde9406aa3e27af9f6 (diff)
downloadaur-bbaad292b20daffda5d86d95a580b62c9a18c40a.tar.gz
Backport some patches to fix compilation issues.
Add missing dependency for FEM. Update to latest 0.18 commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 21 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca7f74fe3585..3508da209f1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,15 +9,15 @@
pkgname=freecad
_pkgver=0.18
-_count=16144
-_commit=5a1527f954c69e022a42d4bbaccdd032996fdfb1
+_count=16145
+_commit=f972b010bb86b39e38e7f59526596bea8b06d954
pkgver=$_pkgver.$_count
pkgrel=1
pkgdesc='A general purpose 3D CAD modeler'
arch=('x86_64')
url='https://www.freecadweb.org/'
license=('LGPL')
-depends=('boost-libs' 'curl' 'opencascade>=7.2' 'xerces-c' 'libspnav' 'glew' 'netcdf'
+depends=('boost-libs' 'curl' 'opencascade>=7.2' 'xerces-c' 'libspnav' 'glew' 'netcdf' 'openmpi'
'shared-mime-info' 'hicolor-icon-theme' 'jsoncpp' 'qt5-base' 'qt5-declarative' 'qt5-svg' 'qt5-tools'
'qt5-x11extras' 'qt5-webkit' 'med' 'python-pivy' 'python-pyside2' 'python-matplotlib' 'pyside2-tools')
makedepends=('boost' 'eigen' 'gcc-fortran' 'swig' 'xerces-c' 'desktop-file-utils' 'git'
@@ -29,6 +29,24 @@ sha256sums=('SKIP'
'617968d7bbd1da71bdedaed1b66c5d6eaf24e0fb34678b93f5d925d370c66296'
'1d98fa4e62f352966eb357c93f54b1f0bf562931e8323bf70a83b5e221a5fb14')
+_backports=(
+ 851e3d9847c5043a604a544b502c51e8c628e96c # add missing std:: namespace to build on Debian 10
+ bf5923c0f360f43703bf0c2d8b1e52ac246a9c11 # add missing std:: namespace to build on Debian 10
+ 2a92051192782930f53f8e3dab011dd8382ca8c3 # add missing std:: namespace to build on Debian 10
+ 50957037764de76bdc0244e5d49f8c5bdcbc4e45 # add missing std:: namespace to build on Debian 10
+)
+
+prepare() {
+ cd "${srcdir}/FreeCAD"
+
+ if ((${#_backports[@]})); then
+ git cherry-pick -x -Xours -Xignore-space-change "${_backports[@]}" \
+ || true # Kind of a hack, but the last commit does not apply cleanly
+ git rm src/Mod/TechDraw/App/Cosmetic.cpp # Fix file not present in 0.18
+ git commit --no-edit
+ fi
+}
+
build() {
cd "${srcdir}/FreeCAD"
PATH=/usr/bin:$PATH # OpenCascade has problems if /bin comes before /usr/bin in the $PATH