summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastiaan Lokhorst2019-11-04 15:26:10 +0100
committerSebastiaan Lokhorst2019-11-04 15:26:10 +0100
commit929b6098c2de2793cd5c2019482403260da33cf6 (patch)
treee5d664f52cbcd79b21dac9a5778b28b3b7da2d47 /PKGBUILD
parente9dfd57429ea87452c1dd6ffc50df11dbb99f1b3 (diff)
downloadaur-929b6098c2de2793cd5c2019482403260da33cf6.tar.gz
Fix pkgver() with chaging 0.19_pre tag
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7165f55cc8b..81b7f88ef35d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
_appname=freecad
pkgname="${_appname}-git"
-pkgver=0.19pre.r2096.gc903de8af7
+pkgver=0.18.r2576.g953b802f83
pkgrel=1
-epoch=1
+epoch=2
pkgdesc='A general purpose 3D CAD modeler - git checkout'
arch=('x86_64')
url='https://www.freecadweb.org/'
@@ -24,7 +24,8 @@ md5sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
- git describe --long --tags --match '*.*' | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/_//'
+ # upstream recyles the "pre" and "staging" tags so they do not produces stable commit counts
+ git describe --long --tags --exclude '*pre*' --exclude '*staging*' | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/_//'
}
build() {