summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGreyson Christoforo2020-11-20 18:14:12 +0000
committerGreyson Christoforo2020-11-20 18:14:12 +0000
commitd57a5fcb92d76f0c1efae028299bfe723aca501f (patch)
tree667554f521f96daab1626e741883396a4381d1b8 /PKGBUILD
parent98256b0b948f1a52e801c8ef1ce9cb3925b09bad (diff)
downloadaur-d57a5fcb92d76f0c1efae028299bfe723aca501f.tar.gz
fix pkgver() function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2eab12dd80b..1e53c12ee0b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
pkgname=freecad-git
-pkgver=0.18.r6973.gc4d42a1f74
-pkgrel=2
+pkgver=0.19_pre.r4405.gc4d42a1f74
+pkgrel=1
epoch=0
pkgdesc='A general purpose 3D CAD modeler - git checkout'
arch=('x86_64')
@@ -20,9 +20,8 @@ source=("git+https://github.com/FreeCAD/FreeCAD.git")
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/FreeCAD"
- # upstream recyles the "pre" and "staging" tags so they do not produce stable commit counts
- git describe --long --tags --exclude '*pre*' --exclude '*staging*' | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/_//'
+ cd FreeCAD
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {