summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastiaan Lokhorst2019-10-20 10:28:27 +0200
committerSebastiaan Lokhorst2019-10-20 10:28:27 +0200
commite9dfd57429ea87452c1dd6ffc50df11dbb99f1b3 (patch)
treec13b5fb8fd0d0b5a9d0292b073eecff36ba14b58 /PKGBUILD
parent5aa12a2cd184b86df2bff1b8ae5846d42c7259e9 (diff)
downloadaur-e9dfd57429ea87452c1dd6ffc50df11dbb99f1b3.tar.gz
Partial undo last commit; there are still issues with pyside
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8359cec77b41..e7165f55cc8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,6 +30,10 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname}"
+ # we need to manually set all PYSIDE_* paths as autodetection is broken:
+ # https://github.com/FreeCAD/FreeCAD/pull/2020
+ PYVER="$(/usr/bin/python3 -c 'import sys; print("{}.{}".format(sys.version_info.major,sys.version_info.minor))')"
+
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr/lib/freecad" \
@@ -39,6 +43,10 @@ build() {
-DBUILD_QT5=ON \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DOPENMPI_INCLUDE_DIRS=/usr/include \
+ -DPYSIDE_INCLUDE_DIR="/usr/include/PySide2" \
+ -DPYSIDE_LIBRARY="/usr/lib/libpyside2.cpython-${PYVER//.}m-${CARCH}-linux-gnu.so" \
+ -DPYSIDE_PYTHONPATH="/usr/lib/python${PYVER}/site-packages/PySide2" \
+ -DPYSIDE_TYPESYSTEMS="/usr/share/PySide2/typesystems" \
.
make
}