summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFélix Piédallu2018-09-21 18:28:58 +0200
committerFélix Piédallu2018-09-21 18:28:58 +0200
commit74a2928cdbdd9b89ab32adb454edd222029fde83 (patch)
tree8162ecca0542b44d6140c0e279313fdd9d925500 /PKGBUILD
parenta40d92e4760d028b12f5d416ec1d8ebdf45332e5 (diff)
downloadaur-74a2928cdbdd9b89ab32adb454edd222029fde83.tar.gz
Add temporary patch for git bugs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8bafab96edc..0ed366a33679 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -67,9 +67,11 @@ optdepends=(
_gitname='FreeCAD'
source=(
"git+https://github.com/realthunder/FreeCAD.git#branch=LinkStage3"
+ 'temporary_fixes.patch'
)
sha256sums=(
'SKIP'
+ 'e6f374849dd96ac198c92ca33082ede99d35d516a1986b09fdbaaa9b4d663e2a'
)
@@ -78,6 +80,11 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/_//'
}
+prepare() {
+ cd "${srcdir}/${_gitname}"
+ patch -Np1 -i "${srcdir}/temporary_fixes.patch"
+}
+
build() {
cd "${srcdir}/${_gitname}"