summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEinhard Leichtfuß2018-03-29 01:24:26 +0200
committerEinhard Leichtfuß2018-03-29 01:24:26 +0200
commit85af2804dfe35899802f6e86361d06a7a3e00e2a (patch)
tree13eb72aec9a4cd31257ce34e51a24b065b8598eb /PKGBUILD
downloadaur-85af2804dfe35899802f6e86361d06a7a3e00e2a.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00a9abfa835a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Einhard Leichtfuß <alguien@respiranto.de>
+pkgname=freedict-tools
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Tools to compile the Freedict dictionaries"
+arch=('any')
+url="http://www.freedict.org/"
+license=('GPL' 'GPL3' 'CC-BY-SA')
+source=("freedict-tools_${pkgver}.tar.gz::https://github.com/freedict/tools/archive/v${pkgver}.tar.gz")
+sha512sums=('60b1d5027cb9609e14bf13c260c1d5e5158b1f23dc631fa625ba1452fbdea37be915bfe2dbe5c0f425ebe930104799d1fb73b398a48066984990e4a0cd7ebb4a')
+
+package()
+{
+ mkdir -p "${pkgdir}/usr/lib/${pkgname}"
+ cp -r tools-${pkgver}/. "${pkgdir}/usr/lib/${pkgname}/"
+
+ mkdir -p "${pkgdir}/usr/share/doc/freedict/tools"
+ ln -s /usr/lib/${pkgname}/README.md \
+ "${pkgdir}/usr/share/doc/freedict/tools/"
+}