summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortee2024-03-26 22:58:31 +1300
committertee2024-03-26 22:58:31 +1300
commit22d37e46eca718ce3c9f9d75a14d3a18658299e4 (patch)
tree52955a4598ff25743d51ef892e76c34dfe739840 /PKGBUILD
parent26bd26487e16b765eab8a7f0bf2c51443605d726 (diff)
downloadaur-22d37e46eca718ce3c9f9d75a14d3a18658299e4.tar.gz
Update to 13.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD117
1 files changed, 34 insertions, 83 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c81647b9655..5c5c9fc3d25b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,108 +1,59 @@
-
# Contributor: chenxing <cxcxcxcx AT gmail DOT com>
# Contributor: Michael Burkhard <Michael DOT Burkhard AT web DOT de>
# Contributor: alexmo82 <25396682 AT live DOT it>
# Contributor: Simon Brulhart <simon@brulhart.me>
# Maintainer: jooch <jooch AT gmx DOT com>
+# Maintainer: tee < teeaur at duck dot com >
pkgname=freefilesync
-pkgver=11.4
+pkgver=13.4
pkgrel=1
pkgdesc="Backup software to synchronize files and folders"
arch=('i686' 'x86_64')
url="https://freefilesync.org"
-license=('GPL3')
-depends=(wxgtk curl lsb-release)
-makedepends=(unzip)
+license=(GPL3)
+depends=(wxwidgets-gtk3)
source=(
- "FreeFileSync_${pkgver}_Source.zip::${url}/download/FreeFileSync_${pkgver}_Source.zip" #ffs
- reversions_11-1.patch
- theme_fixes.patch
- revert_xdg_config_path.patch
- revert_bulk_append.patch
- revert_linkflags.patch
+ "FreeFileSync_${pkgver}_Source.zip.1::${url}/download/FreeFileSync_${pkgver}_Source.zip"
+ "FreeFileSync_${pkgver}_Source.zip::${url}/download/FreeFileSync_${pkgver}_Source.zip"
FreeFileSync.desktop
RealTimeSync.desktop
- dlagent
- )
-
-sha256sums=('d0c20c1388024460944bb0871e91ce6dc9ac5c02be45a095f288db169eb844b4'
- '6c2d7f24e4edc52bc1af95d3f48ef67456cde0b952b81a702901acfb36545999'
- '4f2b1d46c0b754c668be7ec675a2bb09f72b3bd0e20987b4db61575b5ca1bf46'
- '0f9a9a6b2c3c460bbde7425bd62273c925259db1cc9dc18c6013aae99fb15cd8'
- '17e7db683662809882db6d6b3d855eb4372ca1bd05e15c4c490970a0b4b127c0'
- 'c83475ef3ac8bd534d637062d516c9eeea54ac18c775be55e1adef413ac73063'
+)
+noextract=("FreeFileSync_${pkgver}_Source.zip.1")
+sha256sums=('SKIP'
+ 'd1ce076256a1f5a1ec30cc82cff4e3800e7da5371ee21a20cf99fa5dff4cca1a'
'590d87707240529ca893199f852143f5d7c7266cb050e37e615900b013ac3d51'
- '82439b4b81b0a72652befad9b9db52ffbc0180f307c92205aa5ab344f9f82830'
- '1649e7ea66235c6f82daf9beb6b61b7765df54e9ef70f7f6fc1283f5c2b1e54a')
-
-DLAGENTS=("https::./dlagent $url %u %o")
+ '82439b4b81b0a72652befad9b9db52ffbc0180f307c92205aa5ab344f9f82830')
prepare() {
-# wxgtk < 3.1.0
- # Revert to classic config path
- patch -p1 -i revert_xdg_config_path.patch
-
- # Avoid uses of wxItemContainer::Append(const std::vector<wxString>& items)
- patch -p1 -i revert_bulk_append.patch
-
- # edit lines to remove functions that require wxgtk 3.1.x
- sed -e 's:m_textCtrlOfflineActivationKey->ForceUpper:// &:g' -i 'FreeFileSync/Source/ui/small_dlgs.cpp'
- sed -e 's:const double scrollSpeed =:& 6; //:g' -i 'wx+/grid.cpp'
-
- patch -p1 -i reversions_11-1.patch
- grep -RiIl 'wxASCII_STR' | xargs sed -e 's/wxASCII_STR/wxString::FromAscii/g' -i
- grep -RiIl 'wxDD_SHOW_HIDDEN' | xargs sed -e 's/, wxDD_DEFAULT_STYLE | wxDD_SHOW_HIDDEN//g' -i
-
-# undo zenju hacks
- sed -e '71,77d' -i 'wx+/dc.h'
- sed -e '73d' -i 'wx+/no_flicker.h'
-
-# GUI theme fixes (for improved color compatibility)
- patch -p1 -i theme_fixes.patch
-
-# add LINKFLAGS that were removed but that we still need in our case
- patch -p1 -i revert_linkflags.patch
-
-# inlining of constants not present in libssh2's distributed headers
- sed -i 's/MAX_SFTP_READ_SIZE/30000/g' FreeFileSync/Source/afs/sftp.cpp
- sed -i 's/MAX_SFTP_OUTGOING_SIZE/30000/g' FreeFileSync/Source/afs/sftp.cpp
+ bsdunzip FreeFileSync/Build/Resources/Icons.zip {FreeFileSync,RealTimeSync}.png
+ sed -i 's|-2|-3|' FreeFileSync/Source/{Makefile,RealTimeSync/Makefile}
+ sed -i 's|#error|//#error|' FreeFileSync/Source/{application.cpp,RealTimeSync/application.cpp} zen/{string_tools.h,globals.h}
+ sed -i 's|::g_object_ref|g_object_ref|' FreeFileSync/Source/base/icon_loader.cpp
}
build() {
-### speed up compile on multithread machines
- MAKEFLAGS="-j$(nproc)"
-
-### just in case of compile errors
- VER=`g++ -dumpversion`
- MAC=`g++ -dumpmachine`
- echo "compiler g++ $VER $MAC"
-
-### FFS
- cd "${srcdir}/FreeFileSync/Source"
- make exeName=FreeFileSync tmpPath="${srcdir}/FreeFileSync/tmp_ffs"
+ MAKEFLAGS="-s -j`nproc`"
+ CXXFLAGS="$CXXFLAGS -DMAX_SFTP_READ_SIZE=30000 -DMAX_SFTP_OUTGOING_SIZE=30000"
+ LDFLAGS="$LDFLAGS `pkg-config --libs gtk+-3.0`"
-### RTS
- cd "${srcdir}/FreeFileSync/Source/RealTimeSync"
- make exeName=RealTimeSync tmpPath="${srcdir}/FreeFileSync/tmp_rts"
+ make -C"$srcdir/FreeFileSync/Source" exeName=FreeFileSync
+ make -C"$srcdir/FreeFileSync/Source/RealTimeSync" exeName=RealTimeSync
}
package() {
- bindir="${pkgdir}/usr/bin"
- appdir="${pkgdir}/opt/FreeFileSync"
- appdocdir="${pkgdir}/usr/share/doc/FreeFileSync"
-
- cd "${srcdir}/FreeFileSync/Build"
- install -t "${appdir}/Bin" -Dm755 Bin/*
- mkdir -p "${bindir}"
- ln -s /opt/FreeFileSync/Bin/{FreeFileSync,RealTimeSync} "${bindir}"
-
- cp -rT Resources "${appdir}/Resources"
- find "${appdir}/Resources" -type f -print0 | xargs -0 chmod 644
- install -t "${pkgdir}/usr/share/pixmaps" -Dm644 Resources/FreeFileSync.png Resources/RealTimeSync.png
-
- cd "${srcdir}"
- install -d "${appdocdir}"
- gzip < Changelog.txt > "${appdocdir}/CHANGELOG.gz"
- install -Dm644 -t "${pkgdir}/usr/share/applications" FreeFileSync.desktop RealTimeSync.desktop
+ bindir="$pkgdir/usr/bin"
+ appdir="$pkgdir/opt/FreeFileSync"
+ appdocdir="$pkgdir/usr/share/doc/FreeFileSync"
+
+ cd "$srcdir/FreeFileSync/Build"
+ install -Dm755 -t "$appdir/Bin" Bin/*
+ install -Dm644 -t "$appdir/Resources" Resources/*
+ mkdir -p "$bindir"
+ ln -s /opt/FreeFileSync/Bin/{FreeFileSync,RealTimeSync} "$bindir"
+ cd "$srcdir"
+ install -d "$appdocdir"
+ gzip < Changelog.txt > "$appdocdir/CHANGELOG.gz"
+ install -Dm644 -t "$pkgdir/usr/share/pixmaps" FreeFileSync.png RealTimeSync.png
+ install -Dm644 -t "$pkgdir/usr/share/applications" FreeFileSync.desktop RealTimeSync.desktop
}