summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Brulhart2019-11-24 18:21:39 +0100
committerSimon Brulhart2019-11-24 18:21:39 +0100
commit71d76d904ac9e80da71e740c993eb07594c8fb4b (patch)
tree13dd4cd1a444a0e44e5e8a58d345effc8fcd1074 /PKGBUILD
parentd29f9b15d28126d4be928f1aa89b48a6b27fdd2a (diff)
downloadaur-71d76d904ac9e80da71e740c993eb07594c8fb4b.tar.gz
Update to v10.18
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1901b38aba58..f56ff2ba9d41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Maintainer: jooch <jooch AT gmx DOT com>
pkgname=freefilesync
-pkgver=10.17
+pkgver=10.18
pkgrel=1
pkgdesc="Backup software to synchronize files and folders"
arch=('i686' 'x86_64')
@@ -24,9 +24,9 @@ source=(
dlagent
)
-sha256sums=('c833c13cd58ce66b846a3e3fe7dcee11c5cf9f365498a1454b05dc7668478dd3'
+sha256sums=('14160a0855c1fe824fe721edc4d8432d9ce8e4398cc1c759ae91a1b697c00eb1'
'4c62e13fdeafb3263c286718e27a48e8ff127fdcfac39becb45b976e66b6b99f'
- 'e74b4abdf04c58004e52f77afee762e4c3d72d4ca42de4cc42cbc930cbec0e32'
+ 'bd2b786be724818cf232129ecd432f305a5fdecc298a3e503a1e9182cad6a707'
'2ea1f157ab31feb18b0d8ac117a1820174a4b2b9bdaee2027c1fbc2c287e1caa'
'd3dedc100163ce00ae5889a6039a1fff11ae32b676ae5e83ae9182509f80638d'
'590d87707240529ca893199f852143f5d7c7266cb050e37e615900b013ac3d51'
@@ -43,7 +43,7 @@ prepare() {
# Avoid uses of wxItemContainer::Append(const std::vector<wxString>& items)
patch --binary -p1 -i revert_bulk_append.patch
-# edit lines to remove functions that require wxgtk 3.1.x
+ # edit lines to remove functions that require wxgtk 3.1.x
sed -e 's:m_textCtrlOfflineActivationKey->ForceUpper:// &:g' -i 'FreeFileSync/Source/ui/small_dlgs.cpp'
sed -e 's:const double scrollSpeed =:& 6; //:g' -i 'wx+/grid.cpp'
@@ -53,9 +53,6 @@ prepare() {
# add LINKFLAGS that were removed but that we still need in our case
patch -p1 -i revert_linkflags.patch
-# don't try to compile inexistant file
- sed -e '\:CPP_FILES+=afs/libssh2/init_libssh2.cpp:d' -i FreeFileSync/Source/Makefile
-
# inlining of constants not present in libssh2's distributed headers
sed -i 's/MAX_SFTP_READ_SIZE/30000/g' FreeFileSync/Source/afs/sftp.cpp
sed -i 's/MAX_SFTP_OUTGOING_SIZE/30000/g' FreeFileSync/Source/afs/sftp.cpp