summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNori132018-03-17 14:43:38 -0600
committerNori132018-03-17 14:43:38 -0600
commit9e38d5bb025012b928d8d2570561ceb677701fbb (patch)
treeff38f0aea9df46381382a333fb9cfac914526f5c /PKGBUILD
parent9e0c9369421d9732afc1d0b2d48b60ca2b52c7a6 (diff)
downloadaur-9e38d5bb025012b928d8d2570561ceb677701fbb.tar.gz
Removed previous fixes, removed wxgtk 3.1.x dependency, and added lines to edit functions that require wxgtk 3.1.x.
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93c936683868..35d7b4241e5d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,13 @@
pkgname=freefilesync
pkgver=9.9
-pkgrel=4
+pkgrel=5
pkgdesc="Backup software to synchronize files and folders"
arch=('i686' 'x86_64')
url="http://www.freefilesync.org/"
license=('GPLv3')
-depends=(webkit2gtk boost-libs)
-makedepends=(wxgtk-common-dev wxgtk2-dev wxgtk3-dev boost)
-install=${pkgname}.install
+depends=(wxgtk webkit2gtk boost-libs)
+makedepends=(boost)
xbrzver=1.6
source=(
"FreeFileSync_${pkgver}_Source.zip::https://www.freefilesync.org/download_redirect.php?file=FreeFileSync_${pkgver}_Source.zip" #ffs
@@ -21,8 +20,6 @@ source=(
ffsicon.png
RealTimeSync.desktop
rtsicon.png
- freefilesync.install
- wxgtk_fix.sh
)
sha256sums=(
@@ -32,8 +29,6 @@ sha256sums=(
'31df3fa1f1310de14bbd379f891d4f8ed2df5b0d68913eb52c88b3be682933fb' #ffsicon.png
'1502efdbf1638856a18ab9916e0431bf6a53471792cb2daa380345bac33f67c4' #RealTimeSync.desktop
'f28042587dbe99cf5d6bef2c1be4b026488e418e4ba8332b3016d246b7053a4e' #rtsicon.png
- 'a071bbb79fd490001713de7eb0165f37d2f0bba067af152424b3cc50133aa1a3' #freefilesync.install
- '6cc7a2272f063e58d4b3f4519326d4a7b1d14c742eda0e1991c7959f00ffbf75' #wxgtk_fix.sh
)
DLAGENTS=('https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -A Mozilla -o %o %u')
@@ -68,8 +63,9 @@ prepare() {
sed -i "/zlib_wrap.cpp/ a CPP_LIST+=../../xBRZ/src/xbrz.cpp" FreeFileSync/Source/Makefile
sed -i "/popup_dlg_generated.cpp/ a CPP_LIST+=../../../xBRZ/src/xbrz.cpp" FreeFileSync/Source/RealTimeSync/Makefile
-# copy shell file to /usr/bin/
- sudo cp ${srcdir}/wxgtk_fix.sh /usr/bin/
+# edit lines to remove functions that require wxgtk 3.1.x
+ sed -e 's:m_textCtrlOfflineActivationKey->ForceUpper:// &:g' -i 'FreeFileSync/Source/ui/small_dlgs.cpp'
+ sed -e 's:const double scrollSpeed =:& 6; //:g' -i 'wx+/grid.cpp'
}
build() {