summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Krause2016-03-18 01:16:18 +0100
committerChristian Krause2016-03-18 01:16:18 +0100
commit8597b8644ea1d20b6f46ab15a2798da599252074 (patch)
tree3e38e7b22e56fc341f5340b715a858643b8f7a79 /PKGBUILD
downloadaur-8597b8644ea1d20b6f46ab15a2798da599252074.tar.gz
freeorion-0.4.5-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c3630d073a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
+
+pkgname=freeorion
+pkgver=0.4.5
+pkgrel=1
+pkgdesc="turn-based space empire and galactic conquest (4X) computer game"
+arch=('i686' 'x86_64')
+url="https://github.com/freeorion/freeorion/"
+license=('GPL2')
+depends=('boost-libs' 'python2' 'sdl2' 'libvorbis' 'glew' 'libtiff' 'libjpeg-turbo' 'openal' 'hicolor-icon-theme' 'freetype2')
+makedepends=('boost' 'cmake')
+install=freeorion.install
+conflicts=('freeorion-git')
+source=("https://github.com/freeorion/freeorion/releases/download/v${pkgver}/FreeOrion_v${pkgver}_2015-09-01.f203162_Source.tar.gz"
+ 'freeorion.install')
+md5sums=('706b8e9ab2ee29575a927e6f1c772d61'
+ 'bdbd69c55fa91add1f8b17ad7f23ee6d')
+
+prepare() {
+ cd $srcdir/src-tarball
+
+ mkdir -p build
+}
+
+build() {
+ cd $srcdir/src-tarball/build
+
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ ..
+
+ make
+}
+
+package() {
+ cd $srcdir/src-tarball/build
+
+ make DESTDIR=$pkgdir install
+}