summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorthegala2018-08-11 14:17:34 +0200
committerthegala2018-08-11 14:17:34 +0200
commit759c45b78ce605045f98c021349527a1230069d1 (patch)
treea1248eec1d7441c0013ac6e841c36a17629385ec /PKGBUILD
parent5d0ac8345c244bda5c14349469cf3a5da065c917 (diff)
downloadaur-freerouting-git.tar.gz
Update to new version
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-x[-rw-r--r--]PKGBUILD25
1 files changed, 18 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 715aad964e82..d39948495a31 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,36 @@
-# Maintainer: thegala <gala at openaliasbox.org>
+# Maintainer: thegala <thegala at disroot.org>
+# Git repo is not in source because i can't add command line options to git
+# in PKGBUILD
+# I can't provide this in PKGBUILD
+# Read this
+#https://unix.stackexchange.com/questions/154919/how-to-modify-a-pkgbuild-which-uses-git-sources-to-pull-only-a-shallow-clone
+# https://unix.stackexchange.com/questions/373207/how-to-pass-arguments-to-git-from-pkgbuild
+# Also you can fis this problem with adding new dlagent in makgepkg.conf
+
_pkgname=freerouting
pkgname=${_pkgname}-git
-pkgver=20161125.d1459bd
+pkgver=20170512.d61df24
pkgrel=1
pkgdesc="A printed circuit board routing software"
arch=('any')
url="http://www.freerouting.eu/"
license=('GPL')
-depends=('jdk7-openjdk' 'javahelp2' 'icedtea-web')
+depends=('jdk8-openjdk')
makedepends=('git')
-source=('freeroute'
- "${_pkgname}::git+https://github.com/Engidea/FreeRoutingNew.git")
-sha256sums=('bd4f5cf7968a03212463a4f7a051a263b6f0e593e4ee188bdd2b44b696d1c8cb'
- 'SKIP')
+source=('freeroute')
+sha256sums=('bd4f5cf7968a03212463a4f7a051a263b6f0e593e4ee188bdd2b44b696d1c8cb')
pkgver() {
cd "${srcdir}/${_pkgname}"
git log -1 --format='%cd.%h' --date=short | tr -d -
}
+prepare() {
+ cd "${srcdir}"
+ \rm -fr "${srcdir}/${_pkgname}"
+ git clone --depth=1 https://github.com/Engidea/FreeRoutingNew.git ${_pkgname}
+}
build() {
cd "${srcdir}/${_pkgname}"