summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWorMzy Tykashi2024-01-01 12:11:11 +0000
committerWorMzy Tykashi2024-01-01 12:11:11 +0000
commitd3159e511bbbae987458f37c418a0b02bd90a74b (patch)
tree1f3ba00a74727935ac06abfbf7309f0a7152bdea /PKGBUILD
parentc55cc244070766496238954b29e09e61b9acf830 (diff)
downloadaur-d3159e511bbbae987458f37c418a0b02bd90a74b.tar.gz
Include patch to fix cstdint bustage
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 208302a0053b..39b075b86d7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,12 +11,20 @@ depends=('sdl2' 'sdl2_mixer' 'sdl2_image')
makedepends=('cmake' 'libxmp')
optdepends=('libxmp: Amiga audio playback')
install=freeserf.install
-source=(${pkgname}-${pkgver}.tar.xz::"https://github.com/${pkgname}/${pkgname}/releases/download/v${pkgver}/${_pkgname}.tar.xz")
-md5sums=('956fa204197ec29d688b0fbfbb50bd93')
-sha1sums=('24913d2716eff5d71b08a3de8439750d4db627c3')
+source=(${pkgname}-${pkgver}.tar.xz::"https://github.com/${pkgname}/${pkgname}/releases/download/v${pkgver}/${_pkgname}.tar.xz"
+ "cstdint.patch")
+md5sums=('956fa204197ec29d688b0fbfbb50bd93'
+ '98a869d79db05db90d22bf69cdba159d')
+sha1sums=('24913d2716eff5d71b08a3de8439750d4db627c3'
+ 'a451fc22da6d2d7754ddb7f6437d96e99d03df46')
prepare() {
mkdir ${_pkgname}/build
+
+ # Fix cstdint bustage, remove once fixed upstream
+ # https://github.com/freeserf/freeserf/pull/526
+ cd ${_pkgname}
+ patch -p1 -i "${srcdir}/cstdint.patch"
}
build() {