summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrespiranto2015-09-24 10:12:08 +0200
committerrespiranto2015-09-24 10:15:00 +0200
commitcc05bb2193286432f76569caf0d857c445a6a5a2 (patch)
tree81369df7e8cc9307fa5c6319dc9a0215d0a9a114 /PKGBUILD
parent7bd6ee6b311ebd20911d9c6f281e841371e6ec33 (diff)
downloadaur-cc05bb2193286432f76569caf0d857c445a6a5a2.tar.gz
Added some explanations
- using /var/games is doubtable - made change to /var/lib easier
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88509c53703d..2c3088ef668f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: respiranto <respiranto@icloud.com>
pkgname=freesweep
pkgver=0.92
-pkgrel=1
+pkgrel=2
pkgdesc="a console minesweeper-style game written in C for *nix"
arch=('x86_64' 'i686')
url="http://freecode.com/projects/freesweep"
@@ -11,10 +11,17 @@ backup=('etc/sweeprc' "var/games/$pkgname/sweeptimes")
install=$pkgname.install
source=("https://freesweep.googlecode.com/files/freesweep-0.92.tar.gz")
md5sums=('e9ac8d2bc63b5d37863c731e13e023da')
+
# Scores do not really work currently; They are saved,
# but for some reason not read / parsed correctly by the program,
-# i.e. no scores are displayed
+# i.e. no scores are displayed.
+
+# Furthermore it is doubtable whether /var/games/$pkgname
+# is an appropriate location, regarding the Arch Packaging Guidelines.
+# The alternative would be /var/lib/$pkgname.
+# If you change this don't forget to adjust install() appropriately.
_scoresdir="/var/games/$pkgname"
+#_scoresdir="/var/lib/$pkgname"
prepare()
{
@@ -46,9 +53,8 @@ package()
install -m 755 -d "$pkgdir/usr/share/doc/$pkgname"
install -m 644 -t "$pkgdir/usr/share/doc/$pkgname/" README
- # It is doubtable whether /var/games/$pkgname is the appropriate location
- # The alternative would be /var/lib/$pkgname
+ # Comment this line out, if you don't need it:
install -m 775 -g games -d "$pkgdir/var/games"
- install -m 775 -g games -d "$pkgdir/var/games/$pkgname"
- install -m 664 -g games -t "$pkgdir/var/games/$pkgname/" sweeptimes
+ install -m 775 -g games -d "$pkgdir/$_scoresdir"
+ install -m 664 -g games -t "$pkgdir/$_scoresdir/" sweeptimes
}