summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbrent s2016-06-22 17:51:58 -0400
committerbrent s2016-06-22 17:51:58 -0400
commit39676ffffa5f271d9916737cdc02cb905370e48d (patch)
tree9f89e75d2315be9ef17807c6af37217e8f64022c /PKGBUILD
parent7972e0ee0c2bfee2595a315941215ccb853add29 (diff)
downloadaur-39676ffffa5f271d9916737cdc02cb905370e48d.tar.gz
cleaned up. yay!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 3 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c33ae0ec698e..4caed88f09c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,5 @@
# Maintainer: Brent Saner <r00t (at) square-r00t (dot) net>
validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
-# Contributor: TJ Vanderpoel <tj@rubyists.com>
-
-## MAINTAINER NOTE BEGIN
-# Most (like, ~80%) of this is taken verbatim from the freeswitch AUR package currently (as of 02.28.2014) maintained by bougyman.
-# https://aur.archlinux.org/packages/freeswitch/
-# However, it's horribly out of date and doesn't seem to be actively maintained anymore.
-## MAINTAINER NOTE END
-
# This builds the FreeSWITCH open source telephone engine
# from the freeswitch git. It enables the following modules
@@ -23,7 +15,6 @@ validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
# BUILD CONFIGURATION BEGINS #
-
# SET THIS TO GET HIGHER QUALITY SOUNDFILES
# Value can be "hd-", "uhd-", or "cd-" to get 16k, 32k, or 48k sounds.
# By default we only download the 8k sounds. If you only use g711 or
@@ -55,22 +46,11 @@ _enabled_modules=(xml_int/mod_xml_curl
_disabled_modules=(languages/mod_spidermonkey
say/mod_say_ru
dialplans/mod_dialplan_asterisk)
-
-# CONCURRENT BOOTSTRAP
-# Uncomment this to enable backgrounded concurrent bootstrap operations.
-# You will suffer a lot of autotools scroll from this, Fair Warning.
-
-#_concurrent="-j"
-
# BUILD CONFIGURATION ENDS #
-# #
-# CHANGE ANYTHING BELOW HERE AT YOUR OWN RISK! #
-# #
-
pkgname='freeswitch'
pkgver='1.6.9'
-pkgrel='3'
+pkgrel='4'
pkgdesc="An opensource and free (libre, price) telephony system, similar to Asterisk."
arch=('i686' 'x86_64')
url="http://freeswitch.org/"
@@ -157,8 +137,6 @@ disable_module() {
}
build() {
- ln -sf /usr/bin/python2 ${srcdir}/python
- PATH="${srcdir}:${PATH}"
cd ${srcdir}/${_pkgname}
# BUILD BEGINS
@@ -180,11 +158,6 @@ build() {
msg "Module Configuration Complete, Stop Now with Ctrl-C if the above is not correct"
sleep 5
- # SED FIXES
- # per upstream, NO, BAD DOG, NO BISCUIT!
- #sed -i -e '/if\ test\ "\$ac_cv_gcc_supports_w_no_unused_result"\ =\ yes;\ then/,+2d' configure.ac
- #sed -i -e '/\ _BSD_SOURCE$/d' src/include/switch.h
-
# CONFIGURE
./configure --prefix=/var/lib/freeswitch --with-python=/usr/bin/python2 \
--bindir=/usr/bin --sbindir=/usr/sbin --localstatedir=/var \
@@ -201,8 +174,6 @@ build() {
# COMPILE
make
- PATH=${_pathorig}
- rm -f ${srcdir}/python
}
enable_mod_xml() {
@@ -228,17 +199,10 @@ disable_mod_xml() {
}
package() {
- # per upstream, shouldn't be necessary with newer versions. 06.22.2016
- #mkdir -p /var/tmp/bin
- #ln -sf /usr/bin/python2 /var/tmp/bin/python
- #PATH="/var/tmp/bin:${PATH}"
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}/" install
make DESTDIR="${pkgdir}/" ${_sounds}moh-install
make DESTDIR="${pkgdir}/" ${_sounds}sounds-install
- #PATH=${_pathorig}
- #rm -rf /var/tmp/bin/python
- #rmdir /var/tmp/bin
cd ${pkgdir} # MUY IMPORTANT, $PWD is $pkgdir from here on out
# Mangle freeswitch's installed dirs into a more compliant structure,
@@ -267,7 +231,7 @@ package() {
echo "<X-PRE-PROCESS cmd=\"set\" data=\"default_password=$(tr -dc 0-9 < /dev/urandom | head -c10)\"/>" > etc/freeswitch/private/passwords.xml
chmod 700 etc/freeswitch/private
chmod 600 etc/freeswitch/private/passwords.xml
- ln -s /etc/freeswitch var/lib/freeswitch/conf
+ ln -sf /etc/freeswitch var/lib/freeswitch/conf
cp -a etc/freeswitch/* usr/share/doc/freeswitch/examples/conf.default/
for _mod in ${_enabled_modules[@]};do
@@ -280,7 +244,7 @@ package() {
mv etc/freeswitch/* usr/share/doc/freeswitch/examples/conf.archlinux/
rmdir etc/freeswitch
- install -D -m0755 -d usr/share/freeswitch/conf
+ install -D -m 0755 -d usr/share/freeswitch/conf
install -D -m 0755 "${srcdir}/run.freeswitch" usr/share/freeswitch/run
install -D -m 0755 "${srcdir}/run_log.freeswitch" usr/share/freeswitch/log/run
install -D -m 0644 "${srcdir}/conf_log.freeswitch" usr/share/freeswitch/log/conf