summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-19 17:48:45 +0000
committerDaniel Bermond2018-11-19 17:48:45 +0000
commitf5d86a6a07981c371f3cd962c804b6728955af86 (patch)
treeb3c61a7585b0ac5cf6a4d29f7cafa251e8af96b3 /PKGBUILD
parent9bc046f914aa03e0c840c8337fb507f87accd01b (diff)
downloadaur-f5d86a6a07981c371f3cd962c804b6728955af86.tar.gz
Do not rename de source clone. General improvements.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 84e2ea0686d7..853cc394e65c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer: Daniel Bermond < gmail-com: danielbermond >
pkgname=frei0r-plugins-git
-pkgver=1.6.1.r2.g410c43b
+_srcname=frei0r
+pkgver=1.6.1.r49.g07146e3
pkgrel=1
pkgdesc='A minimalistic plugin API for video effects (git version)'
arch=('i686' 'x86_64')
@@ -12,18 +13,23 @@ makedepends=('git' 'opencv')
optdepends=('opencv: for facebl0r and facedetect plugins')
provides=('frei0r-plugins')
conflicts=('frei0r-plugins')
-source=("$pkgname"::'git+https://github.com/dyne/frei0r.git')
+source=('git+https://github.com/dyne/frei0r.git')
sha256sums=('SKIP')
+prepare() {
+ cd "$_srcname"
+
+ ./autogen.sh
+}
+
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
+
printf '%s' "$(git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//')"
}
build() {
- cd "$pkgname"
-
- ./autogen.sh
+ cd "$_srcname"
./configure \
--prefix='/usr' \
@@ -31,11 +37,14 @@ build() {
--enable-shared='yes' \
--enable-fast-install='yes' \
--enable-cpuflags
+
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
- cd "$pkgname"
+ cd "$_srcname"
+
make DESTDIR="$pkgdir" install
}